RAK5860 WisBlock Nb-Iot BG77 Series GNSS


Any good news from the SW Team ? Please let me know if I can do something at my side. Thanks,


Please check the following advice from our SW team:

  1. Check GPS antenna connection
  2. Test outside with a clear view to the sky
  3. As it can take a long time until a location is acquired, please change the example code

around line 95: int gps_count = 100 change to int gps_count = 500.
around line 144: bg77_at("AT+QGPSLOC?", 1000);1 change to bg77_at(β€œAT+QGPSLOC?”, 10000);`

1 Like

Ok Sir. I will do again and again !

The RAK5010 and RAK 8212/RAK8212-M modules give satellite fix with 7 to 8 satellite fix in short time from same place from where I’m using my WisBlock Modules.

I have to check with different GPS Antenna ?

Have You feedback from different Country/Continent users of RAK5860 about this code if it’s working for them ?

Very appreciate if somebody can send one successful Log file running the above code and not let me to fight alone !


The RAK Sw team advices to me are are not welcomed !
They must to be more careful about who is the target of they stupid advices !


  1. Check GPS antenna connection

  1. Test outside with a clear view to the sky !


The Log:

18:28:17.546 β†’ RAK11200 Cellular TEST With Hologram sim card!
18:28:21.523 β†’ Modem response after start:
18:28:21.523 β†’ ATI

18:28:21.523 β†’ Quectel
18:28:21.523 β†’ BG77
18:28:21.523 β†’ Revision: BG77LAR02A02
18:28:21.523 β†’
18:28:21.523 β†’ OK
18:28:21.523 β†’
18:28:21.523 β†’ BG77 power up!
18:28:22.036 β†’ AT+CFUN=1,0

18:28:22.036 β†’ OK
18:28:22.036 β†’
18:28:24.982 β†’ AT+CPIN?

18:28:24.982 β†’ +CPIN: READY
18:28:24.982 β†’
18:28:24.982 β†’ OK
18:28:24.982 β†’
18:28:27.051 β†’ AT+QNWINFO

18:28:27.051 β†’ +QNWINFO: β€œeMTC”,β€œ53001”,β€œLTE BAND 3”,1917
18:28:27.051 β†’
18:28:27.051 β†’ OK
18:28:27.051 β†’
18:28:29.540 β†’ AT+QCSQ

18:28:29.540 β†’ +QCSQ: β€œeMTC”,-74,-97,229,-11
18:28:29.540 β†’
18:28:29.540 β†’ OK
18:28:29.540 β†’
18:28:32.011 β†’ AT+CSQ

18:28:32.011 β†’ +CSQ: 20,99
18:28:32.011 β†’
18:28:32.011 β†’ OK
18:28:32.011 β†’
18:28:36.968 β†’ AT+QIACT=1

18:28:36.968 β†’ ERROR
18:28:36.968 β†’
18:28:43.847 β†’ AT+QIOPEN=1,0,β€œTCP”,β€œcloudsocket.hologram.io”,9999,0,1

18:28:43.847 β†’ OK
18:28:43.847 β†’
18:28:43.847 β†’ +,
18:28:45.857 β†’ Send test data to Hologram via TCP!
18:28:46.839 β†’ AT+QGPS=1,1

18:29:14.635 β†’ AT+QGPSEND

18:29:17.583 β†’
18:29:20.579 β†’
18:34:21.581 β†’ Send test data to Hologram via TCP!
18:34:22.568 β†’
18:34:22.568 β†’ OK
18:34:22.568 β†’ AT+QGPS=1,1

18:34:34.191 β†’ AT+QGPSEND

18:34:37.140 β†’
18:34:40.141 β†’
18:39:41.138 β†’ Send test data to Hologram via TCP!
18:39:42.114 β†’
18:39:42.114 β†’ OK
18:39:42.114 β†’ AT+QGPS=1,1

18:39:54.820 β†’ AT+QGPSEND

18:39:57.782 β†’
18:40:00.752 β†’
18:45:01.826 β†’ Send test data to Hologram via TCP!
18:45:02.754 β†’
18:45:02.754 β†’ OK
18:45:02.754 β†’ AT+QGPS=1,1

18:45:14.391 β†’ AT+QGPSEND

18:45:17.321 β†’
18:45:20.344 β†’

Any new advices to check Sirs ?

Shouldn’t not be a big issue to your intl. company to show your bright solving this issue but it is…
I can use your RAK5010/m devices until you figure out what it’s happening with this module. Don’t worry, still addict to RAK products…

1 Like

Attached Log file from China:

HW engineering forgot to tell that it is required to have 3V3_S enabled because it is used as supply for the GPS antenna.

Please add
#define BG77_GPS_ENABLE 34 into the sketch.

  digitalWrite(BG77_GPS_ENABLE, 1);

into the setup() function.

Woow ! Thank You Sir ! Just please some time to check ! !!!

What its the gnss message? Longitude/Latitudes… ? We are going round and around dear friends. We have no gps coordinates from this WisBlock Devices ! Shame of you gurus to spend our time and money for nothing !

It is all in the Quectel data sheets. You just need to read.

Yep. I sended To You Sir the link to this documentation. Do You remember ?

How many times i should repeat to you guys? Who even buy WISBLOCK5860 are losers like me! Are you not listening ?

The RAK5860 WisBlock Module are expensive. For what we, can’t afford to be cheated by companies like RakWireless !

Hi. Goood News !!!

Finally I got GPS Data after ~2 months of messaging.

The following sequence of code from Bernd solved this issue !

#define BG77_GPS_ENABLE 34 into the sketch.

digitalWrite(BG77_GPS_ENABLE, 1);

Thank You

1 Like

I think my 5860 is broken… no respons anymore.
I used also the sketch from Bernd but unfortunately no serial port data in return

16:29:56.580 β†’ RAK11200 Cellular TEST With Hologram sim card!
16:30:04.575 β†’ BG77 power up!
16:30:05.047 β†’
16:30:07.541 β†’
16:30:10.036 β†’
16:30:12.569 β†’
16:30:15.057 β†’
16:30:20.009 β†’
16:30:26.885 β†’
16:30:28.865 β†’ Send test data to Hologram via TCP!
16:30:29.859 β†’

On 5860 module: Green LED is flashing partly and Blue LED is ON

any advise?

BR, Jeroen

Blue LED => BG77 is powered up.
Green LED flashing => no connection or trying to connect.

But no response from the Chip is strange.
Any other modules plugged into RAK5005-O base board?
Did you try to unplug the RAk5860 from the RAK5005-O and reconnect it?

Hi Bernd,

No other modules are plugged into the base board and yes I already reseat, reinstalled the RAK5860 module.
Hmm, still investigating but I’m little bit scared the module is broken, do you think?


I don’t have a RAK5860 to test, but if you connect your PC to the USB connector on the RAK5860, can you get any output from there? You should be able to see some output and send AT commands from a Serial Terminal on your computer.

Nope, there isn’t either a serial COM port available when connecting to the RAK5860 USB port.
When power it up via de baseport and connectng te USB also to the RAK5860 directly I got:


When conecting a terminal to NMEA port I see very nice correct GPS data:

When connecting to the DM port, no data seen on the terminal port.

Looks like it is not passing back to the mainboard?

Hi there.

Same issue here. Same code/same hardware for ~4Γ·5days worked well and suddenly they stopped to work.
I made experience with 2 more brand new module with different sim cards (Vodafone/Spark/Hologram) and same result I got. What happenning?
On the Com17/Com14 I have same result at my side what Jeroen got in nl.
Another question. What is the WisBlock acceleration interrupt port ? Clearly not 21 !