Rak7200 don't send GPS data

Ciao!
I’m Giovanni from Italy,
I also wrote to the assistance but I would like to talk to the community to improve my knowledge.

Issue:

it doesn’t seem to send out GPS coordinate information but only:

    "acceleration_x": "0.041g",
    "acceleration_y": "0.022g",
    "acceleration_z": "0.95g",
    "battery": "3.9V",
    "gyroscope_x": "-0.78°/s",
    "gyroscope_y": "-0.23°/s",
    "gyroscope_z": "-0.02°/s",
    "magnetometer_x": "-2.7μT",
    "magnetometer_y": "54μT",
    "magnetometer_z": "7.65μT"

Setup:

RAK7200 version:3.1.0.13
===============Device Status List================
Board Core: S76G_B
MCU: STM32L073RZ
LoRa chip: SX1276

Battery Voltage = 3.899 V
Support Gps:true
gps_timeout: 120s
gps_format:GPS take six decimal places
No signal with Satellite.

MPU9250 sensor:
Acceleration(g) of X,Y,Z:
0.00,0.00,0.00
Gyro(degress/s) of X,Y,Z:
0.00,0.00,0.00
Magnetometer(uT) of X,Y,Z:
0.00,0.00,0.00
===================List End======================

at+get_config=lora:status

OK Work Mode: LoRaWAN
Region: EU868
Send_interval: 120s
Auto send status: true.
Send_interval work at sleep
Join_mode: OTAA
DevEui: xxxx
AppEui: xxxx
AppKey: xxxx
Class: A
Joined Network:false
IsConfirm: unconfirm
AdrEnable: false
EnableRepeaterSupport: false
RX2_CHANNEL_FREQUENCY: 0, RX2_CHANNEL_DR:0
RX_WINDOW_DURATION: 0ms
RECEIVE_DELAY_1: 0ms
RECEIVE_DELAY_2: 0ms
JOIN_ACCEPT_DELAY_1: 0ms
JOIN_ACCEPT_DELAY_2: 0ms
Current Datarate: 0
Primeval Datarate: 5
ChannelsTxPower: 0
UpLinkCounter: 0
DownLinkCounter: 0

Server:

TTN v3
https://eu1.cloud.thethings.network/

Details:

I use this decoder:

https://github.com/RAKWireless/RUI_LoRa_node_payload_decoder/blob/master/RUISensorDataDecoder_GPS6digitPrecison_for_ChirpStack.js

i updated today to the latest firmware

I just can’t figure out what’s wrong.

Ciao,
after many configuration attempts, now it seems that the GPS data appears:

{
“name”: “as.up.data.forward”,
“time”: “2022-08-17T09:22:52.100131849Z”,
“identifiers”: [
{
“device_ids”: {
“device_id”: “eui-private”,
“application_ids”: {
“application_id”: “rak7200-2”
},
“dev_eui”: “private”,
“join_eui”: “private”,
“dev_addr”: “private”
}
}
],
“data”: {
@type”: “type.googleapis.com/ttn.lorawan.v3.ApplicationUp”,
“end_device_ids”: {
“device_id”: “eui-private”,
“application_ids”: {
“application_id”: “rak7200-2”
},
“dev_eui”: “private”,
“join_eui”: “private”,
“dev_addr”: “private”
},
“correlation_ids”: [
“as:up:01GANHSQHXFCFXS3AM9F1AQ9PA”,
“gs:conn:01GANHSN9N5PWRKNYHHV9XS64H”,
“gs:up:host:01GANHSN9XMRC72XKHNTG4YR74”,
“gs:uplink:01GANHSQBEM4HQ6YZ42ST9XRA0”,
“ns:uplink:01GANHSQBE6E9W7NR2JCYHY0RW”,
“rpc:/ttn.lorawan.v3.GsNs/HandleUplink:01GANHSQBESN0W5YHK4MM3K2GE”,
“rpc:/ttn.lorawan.v3.NsAs/HandleUplink:01GANHSQHX7ZPV9V2WQ85J919M”
],
“received_at”: “2022-08-17T09:22:52.093993285Z”,
“uplink_message”: {
“session_key_id”: “private==”,
“f_port”: 8,
“f_cnt”: 46,
“frm_payload”: “CAIBgQNx/9oAcgO1BYb/yv/7AAAJAgINCgIY9gsCBM4=”,
“decoded_payload”: {
“acceleration_x”: “-0.038g”,
“acceleration_y”: “0.114g”,
“acceleration_z”: “0.949g”,
“battery”: “3.85V”,
“gyroscope_x”: “-0.54°/s”,
“gyroscope_y”: “-0.05°/s”,
“gyroscope_z”: “0°/s”,
“magnetometer_x”: “5.25μT”,
“magnetometer_y”: “63.9μT”,
“magnetometer_z”: “12.3μT”
},
“rx_metadata”: [
{
“gateway_ids”: {
“gateway_id”: “ttner-a001”,
“eui”: “3338333037002B00”
},
“timestamp”: 3429253072,
“rssi”: -107,
“channel_rssi”: -107,
“snr”: 10,
“location”: {
“latitude”: 44.210982,
“longitude”: 11.598254,
“altitude”: 500,
“source”: “SOURCE_REGISTRY”
},
“uplink_token”: “private=”,
“received_at”: “2022-08-17T09:22:51.886203992Z”
}
],
“settings”: {
“data_rate”: {
“lora”: {
“bandwidth”: 125000,
“spreading_factor”: 8
}
},
“coding_rate”: “4/5”,
“frequency”: “868100000”,
“timestamp”: 3429253072
},
“received_at”: “2022-08-17T09:22:51.886693990Z”,
“confirmed”: true,
“consumed_airtime”: “0.174592s”,
“network_ids”: {
“net_id”: “000013”,
“tenant_id”: “ttn”,
“cluster_id”: “eu1”,
“cluster_address”: “eu1.cloud.thethings.network”
}
}
},
“correlation_ids”: [
“as:up:private”,
“gs:conn:private”,
“gs:up:host:private”,
“gs:uplink:private”,
“ns:uplink:private”,
“rpc:/ttn.lorawan.v3.GsNs/HandleUplink:private”,
“rpc:/ttn.lorawan.v3.NsAs/HandleUplink:private”
],
“origin”: “ip-10-100-14-249.eu-west-1.compute.internal”,
“context”: {
“tenant-id”: “CgN0dG4=”
},
“visibility”: {
“rights”: [
“RIGHT_APPLICATION_TRAFFIC_READ”
]
},
“unique_id”: “private”
}

But neither TTN nor the other service I use (signomix) receive the GPS data.
Is it possible that the reason is that latitude, longitude, altitude appear twice in the payload? (gateway data)

Understanding end device location settings

The Things Stack is capable of storing locations from multiple sources at the same time.

how can I solve this problem?