Rak7200 not responding

Hello, I have a problem with my Rak7200.
I killed old firmware and upgraded firmware with STM32CubeProgrammer+
Current Version is RAK7200_V3.1.0.13
Bootloader is V3.1.1

I also tried with previous Version, if I click on some commands, I dont get any responds, like on the screenshot

I dont know what to do, can you help pls?

Hello @hamsitava

After you connect RAK7200 with the USB cable and open the correct port, can you press the Reset button on the device and check if there is any response in the Serial Port Tool?

Hello Martin,
I tried to reset & boot button several times, still no response in the serial port tool

From where did you find the firmware? Also, is the battery connected to the board?

I got the firmware from https://downloads.rakwireless.com/LoRa/RAK7200-Tracker/Firmware/

Yes, battery is connected

Try to flash that firmware using this tool: https://downloads.rakwireless.com/LoRa/RAK612-LoRaButton/Tools/RAK%20LoRaButton%20Upgrade%20Tool%20V1.0.zip

When you select the firmware and the COM port and press Start do the following:
Hold down the BOOT0 button, and then press the Reset button.
Release the Reset button, then release the BOOT0 button.
and check if the firmware is flashing.

I tried several firmwares, always same error