RAK7201 stuck in download mode

I’m trying to get my new RAK7201 LoRa button working, and wasn’t having much luck. Since I’ve have firmware version issues with several other sensors, I decided to update the firmware on it to the latest 915MHz version.

The “Hyperterm” included with the git is in Chinese, which makes it unusable for me. I tried Teraterm, but it caused aborts when I tried to download. I went back to “Hyperterm” and tried to guess the proper inputs based on the getting-started document. Unfortunately, I’ve ended with a unit that won’t stop trying to download the firmware. All I get are the repeated "C"s. Unplugging and replugging the USB cable has no effect. Opening the serial port in any terminal program just results in the "C"s. No button presses on the device has any effect. The blue lights on buttons 1 & 3 are blue.

How can I reset the device?

Due to the battery power supply, RAK7201 enters the mode of receiving firmware.
The solution

  1. Open the RAK7201 case, break the battery again and connect it again, and force restart.
  2. Leave it for at least one day and disconnect the USB connection to drain the battery. Connect it to the USB again and restart.
    This will bring RAK7201 back to its original state. If you need to upgrade the firmware, please do so in the correct document order. :grin: :grin: :grin: :grin:
1 Like

Forced restart first need to remove the waterproof plug, then remove the screw to open.

I popped the unit open, removed the battery, and then plugged it into USB and shorted the nRESET pin on the module. That worked. I was able, this time, to update the firmware.

A couple of notes: after changing the join mode to OOTA, the unit would not successfully join. I had to do a soft reset to make it work.

It would be great if you could add a “at+version” command that would also display the frequency band, and a single command that would dump all of the status.

Restart function can be achieved :1. Long press 2, will achieve the restart 2. Through the command: at+reset
Since only EU868 and US915 are currently supported, there will be a note on the shell.

1 Like

The RAK7201 you had in hand in Beta Sample version. This version with limited memory space and our V2(commercialize version) will increase the larger space but firmware procedure is same. In the V2 version due to the large memory space, we can support multiple regional parameter selection so no need to re-download the firmware if you want to change the setting. Sorry for this inconvenience caused

Ah, I see. I went back and looked, and I had ordered the RAK612. It would have been good to let me know that you had substituted a Beta version. It is fine, but it caused confusion.

When will the V2 version be available?

Nicholas, i would suggest that you add that to the getting started guide. It’s very handy to know.

Is Button_4key the right git repository for the source code? I’d like to add support for turning on the LEDs remotely. And which IDE is used, Attolic?

V2 will be released in 6 weeks later. It will base on SX1262 chip and we also improve the memory space to build API to easy for you to customize application layer. Sorry for the confusion. We only select few customer to ship with RAk7201 V1 since RAk612 is no stock now.

1 Like