RAK7243 GW Problems


I have been running a node for one day, then it eventually just stops working. Can’t get a OTAA, or when running the package util it doesn’t receive anything.

I bought a RAK7243 GW some time ago and I have had a lot of problems getting it to work consistently. I have tried both on US915 and EU863 bands. I have tried both installing the image provided by the RAK documentation as well as a fresh installation of Raspian and installing from source (the Github page). It works, but very inconsistent.

My nodes are Pycom devices, and I have tried with several (LoPy4 and FiPy) and different firmwares. The GW is connected to the internet. DNS and everything is OK. The GW shows up as connected in the TTN console (this has never been a problem).

I am not sure what the next step is, seems that I cannot get my head around why it works sometimes but not always.

As described in the protocol, each frequency band has multiple channels and RAK7243 can only use eight of them. It needs to select the same channel as the node. Can you query the channel of the node to make the gateway consistent with it? Maybe that’s the problemimage

Hi, thank you for your answer. When trying to join (with a Pycom-device) on the US915 band it never gets an OTAA accept, I can see in the TTN-portal that the join downlink is sent but in never gets through to the device. I suppose this is because of a mismatch between channel specifications. That’s why I am trying out with the EU868-band as it at least works out of the box with the Pycom-devices (this is only for development).

But, what have happened several times is that all seems to work well and fine with a node sending a couple of bytes to the TTN each minute. Can be running for a day, but then eventually it stops working and I cannot seem to figure out what has changed or not. It might be the that the Node and GW are operating on different channels, I’ll look into this.

Can send data to the gateway through other nodes when ie stop working?

Hi, just because I opened a support ticket it has been working consistently for 3 days now. But yes, I did try other nodes (FiPy and LoPy4) before when I experienced problems. But as you suggested, it is possibly not HW related, but if running on the wrong channels it will be the same in that case.

Because some nodes will do the full channel of the transmission, it will not affect the normal data transmission.

Hello, can you log in to the gateway through ssh and execute "gateway-version" to check the version number of the gateway?

Hi, output as below. And I did install a clean install of Debian this time, as I want to have control over my dist.

I have had a node up and running without any problems for four days at EU868, I will try the US915 as the next step.

Raspberry Pi 3 Model B Plus Rev 1.3, OS "10 (buster)", 4.19.97-v7+.
RAKWireless gateway RAK7243 no LTE version 4.2.0R install from source code.

Thank you for your suggestion, we will test US915 to find the cause of the problem.

I have now tested the US915 setup, and there seems to be some kind of mismatch between the channels. I can get the node to join, but it’s seldom any uplink messages that get through. Have not managed to get downlink messages at all. I am using both LoPy4 and FiPy devices, flashed with their newest FW (both the legacy version and their Pybytes firmware).

We just used the rak811 node to test the US915 frequency band, joining and sending data about 100 times, with a success rate of 95%.

We will continue to test.

@frahlg Now US915 has returned to normal, you can try again, and you can feedback whether there is still a problem at any time.