RAK7243C LTE : GSM Timeout


I’m testing a RAK7243C with LTE gateway. Everything seems to work fine BUT.
Every 24 hours GSM data in ppp0 go back to 4 bytes (4 in and 4 out).
When this issue occurs the gateway appears disconnected in TTN Console.

  • ping www.google.fr doesn’t give ping back.
  • By killing process using AMA serial port and quickly connecting through minicom or with pppd call gprs everything seems to be fine.
  • Sim card works great in other gateway brand with same network and settings.

The solution is rebooting. sudo reboot correct the problem. But I can’t stand behind the screen everyday. And I need to setup this gateway without screen or keyboard.

Is it possible to build a reliable gateway with this setup???

Thanks a lot.

I’ve checked the maximum speed of LTE connection through apt-get update max speed is about 10kB/sec. With wired connection it’s closed to the maximum we can reach here.

How can I know the actual GSM mode (2G 3G 4G…) ?

I think that it’s 2G max for the moment.

Thanks for your help.

The default rate of ttyAMA0 is 115200, and the maximum rate is 14KB/s.
The speed of ttyAMA0 can be changed to 921600, which is 112KB/s.

I think the model of your lte module is BG96, you can check it by ATI command in minicom.
The following figure is all the bands supported by BG96.

If your sim card supports 4G and the LTE module supports the frequency band of the sim card, you can refer to the following steps to change::
1.Use command "sudo gateway-config", disalbe lte module, then reboot gateway.

2.Use command minicon connect to the lte module
minicom -D /dev/ttyAMA0 -b 115200

3.Input "at+ipr=921600"

4.exit minicom

5.Use command minicon connect to the lte module
minicom -D /dev/ttyAMA0 -b 921600

6.Input "at&w"

7.exit mimnicom

8.Use command "sudo gateway-config", Choose "Configure APN name", set the APN name and new baud rate(921600) for pppd

9.Choose "Configure LTE Module", select "Enable LTE Module", then reboot gateway.

Regarding your first question, the network will be disconnected after 24 consecutive hours, and we will give you the results after the test.

If your LTE module is EG95, the following figure shows the frequency bands supported by EG95.


Many thanks for your help! Yes, for speed it was logic ^^ . I didn’t think about serial port speed limitations :wink:

I’ve made the corrections exactly as you tell and now it’s correct.

My LTE Module is EG95.
I’ve rebooted the Pi this morning. Wait for 24 hours to see what happens.

Have a good day (or night…)


I still got the same problem. after 24h the GSM connection breaks.
Packet Forwarder is not able to connect and loop restart.

GPS never find the coordinate and before GSM breaks it displays WARNING: failed to close GPS successfully in the log.

Still need help…

Please :slight_smile:

Hello, I tested the lte module for 66 hours, from 15pm on January 15th to now (9am on January 18th).
pppd dial-up is stable and not disconnected.
But lora had several restarts on January 17. Because I use a 2G network, it may be caused by unstable signal quality.


Many Thanks for your answer!
My Gateway still disconnect every 24hours.

GPS never give any signals, coordinate or time.

I think this is the problem. It looks like a conflict.

Any idea???

1.Is the GPS of the gateway connected to an antenna and placed it outdoors?
2.Please send me the printed information of "gateway-version".
3.Please send me the printed information of "cat /opt/ttn-gateway/packet_forwarder/lora_pkt_fwd/global_conf.json | grep gps_tty_path".

Do you have an account for instant messaging software? Such as skype, wechat, whatsapp, etc.

gateway-version :
Gateway ID:B827EBFFFE137A88
RAKWireless gateway RAK7243 version 4.1.0R

and “gps_tty_path”: “/dev/i2c-1”,

Yes, GPS antenna is well pluged and Antenna is outside with sky view. Another (non LTE) rak gateway is working fine close to this one!

I’ve got 3 RAK gateway and no issues with ethernet version!

I’ve got a discord account

Jean-Philippe BILLAUDEL#3681

I just sent you a request to add.