RAK7246G not connecting to TTN

Issue: I setup RAK7246G to connect to TTN as per this doc Quick Start Guide | RAKwireless Documentation Center
But Gateway is not connecting to TTN Console.

Selected 2 Setup RAK Gateway LoRa concentratorServer is TTN8 US_902_928

On TTN Console selected US_902_928_FSB_2 as Frequency plan
after this rebooted the gateway

Noticed /usr/local/rak/gateway-config-info.json had a wrong lora_server_ip, so updated it to nam1.cloud.thethings.network (but it didn’t help)

Server: nam1.cloud.thethings.network


Raspberry Pi Zero W Rev 1.1, OS “10 (buster)”, 4.19.75+.
RAKWireless gateway RAK7246 version 4.2.0R install from firmware.
Gateway ID: ##################.

appreciate any help her.

Hei @rp346,

This tutorial is a bit outdated let me do some tests and see if I can solve your issue.



Just tested with this firmware:

It is a bit newer than yours, still you need to replace the address of the server in the packet forwarder file as you did before. It did work for me once I did this for the EU868 as I don’t have an US915 unit not being in the US.
Can you try the firmware I used and see what happens?



Can you also run this script once you have finished configuring to see what the log says:
Go to the following folder:
Run the command

Share the logs.


I jsut noticed that you did not actually edit the packet forwarder file, as I did.
This is probably the issue, you need to update the packet forwarder file, the easiest way to do it is via the sudo gateway-config script.

This will open the file, go to the end and update the server address. Exit save and restart the packet forwarder with the 3-rd script option. This should get you working.


TTN v2 console going read only on 1st July.

Will there be a new image released with the new gateway server addresses?

After doing this, gateway was connected to TTN. Thanks

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.