RAK7249 Built-in server not working properly

Issue: RAK7249 gateway inbuilt server not functioning properly.

Setup: RAK7249

LoRa® Server: RAK Built-in server

Details: After discussing with RAK Team that there is an availability of the Built-in server in the gateway. I have purchased RAK7249. But due to some firmware issue, it is not functioning properly, I hope the RAK team will help me out to resolve this soon.

Without any indication of what “not functioning properly” means, no one will know where to start.

What do you do, what do you expect to see, what actually happens?

Hello @nmcc,
I have purchased the RAK7249 after discussing with your team that it got built-in server, which I wanted to use for my application. after purchasing now while implementing the end nodes are joining successfully and sending data to the server but unable to push the data through HTTP integration. Your support person tried hard but failed to get it done and at the end claiming that There is an issue with the end node but in my case, I have tried multiple end nodes but no use the gateway not performing well. Task performed are as below
1.Changed the firmware.
2.Restored the gateway several time.
3.Changed the nodes joined and rejoined reflashed.
but it’s registering and getting the data but unable to push it using http integration.
I just want to get it working in any condition.

I’m a forum member like you, just a geek trying to help out fellow geeks, not a staff member, but considered useful enough to be tagged as a “Trusted RAKstar”.

If the data is getting to the application server, that’s good. Changing that side of thing shouldn’t make any difference to the what happens next so I’d not see how changing firmware & device setups would help.

So, what is it that happens when you setup an HTTP integration??

Thankfully this is the simplest of the integrations, you give it a web address, it sends the data to that address - for which you can use any number of test end points on the internet to test with.

Thank you for your interest in this, Exactly that is what I’m asking and stuck at when the device continuously generating the data the built-in server should actually push data through HTTP integration which is not happening:( tried out all possible things but of no use not getting the data.

I get that it is not sending the data but I’m not clear on what you have setup on the RAK7249 and if you have an end-point that you can check in your browser to make sure it is responding.

Please go through this link
Supported LoRa Network Servers | RAKwireless Documentation Center

Check for built-in server configuration the gateway is not working as per that for me.

No, I’m good thanks, I know where the buttons are. And again, a very vague assertion that it’s not working.

But it doesn’t tell me what YOU have setup. And it doesn’t answer the question about if your end-point (the web address / URL) is receiving anything at all and if it responds when you use the URL in your browser.

FYI, I did a TTS conference session on HTTP Integration so I do know about this stuff.

i.node joined with gateway

ii. Integrated to webhooks with end URL https://webhook.site/66834883-0800-4e31-bfb4-ea6d6e3b7a76

iii.Triggering the nodes frequently for data

iv. No data in webhooks

I’m struggling to get the data out of this, I hope you clearly understood now.

1 Like

Anything in the gateway log about sending the http request?

As it’s a self-contained gateway running the stack, it’s worth checking the DNS entries are OK so that it can reach the webhook.site.

I have Enabled HTTP integrations and made required settings like configuring and checking entries in diagnosis gateway is able to ping it

Hmmmm, this is strange.

Can you get a network tool like WireShark to see what the traffic between the gateway and the webhook.site is?