RAK7249 DDNS settings

Hi there,

Im trying to setup the Dynamic DNS service to connect to my RAK7249 via cellular. I have created an account and generated a hostname through Dyn. com and listed the current IP address as the 7249’s IP listed under the IPv4 address listed in the cellular.

Under the Dynamic DNS Basic Settings i have listed

  • Lookup Hostname: XXXX.dyndns. org
  • DDNS Service provider [IPv4]: dyn. com
  • Hostname/Domain: dyndns. com
  • Username: username for dyn. com account
  • Password: password for dyn. com account

Under Advanced Settings:

  • IP address source [IPv4]: Network
  • Network [IPv4]: wan
  • All other settings on this have been left blank

After clicking ‘Save & Apply’ i check the Read log file and get the following error

100919 ERROR : BusyBox nslookup error: ‘1’
100919 : nslookup: can’t resolve ‘XXXX .dyndns.org’: Name or service not known
100919 WARN : Get registered/public IP for ‘XXXX .dyndns.org’ failed - retry 3/0 in 60 seconds
101019 : #> /usr/bin/nslookup XXXX.dyndns.org >/var/run/ddns/myddns_ipv4.dat
2>/var/run/ddns/myddns_ipv4.err

Any help would be appreciated.

Beyond a general suspicious that using this is probably a bad idea (consider instead a VPN or setting up a tunnel to a bastion host), I notice you have some random spaces appearing in address strings which shouldn’t be there.

hi chris,

yeah as a new forum user, apparently my posts can only have a limit of 2 links posted, hence i had to put a space in there.

Im having a look at the VPN avenue, however theres little to no documentation that i can find on RAK docs or forum regarding setting it up.

thanks

Hi @rowanb I share the link to OpenVPN tutorial in another topic with you, here is the DDNS tutorial RAKwireless DDNS tutorial
Here is the OpenVPN :slight_smile: RAKwireless OpenVPN tutorial

1 Like

Hi @velev. The instructions in the link are well laid out. However i couldnt get Dyndnss.net to update the correct IP. it appeared the only address it would point my hostname to was the IP i was using from my computer to access to website.

The RAK7249 log indicates that it is successfully updating the registered IP at dyndnss with the IP address listed as the IPv4 address.

005005 info : Update successful - IP ‘22.0.182.XXX’ send
005005 info : Forced update successful - IP: ‘22.0.182.XXX’ send
005005 : Waiting 600 seconds (Check Interval)

When i refresh the dyndnss page my IP address is still listed as the IP from this computer. Should it be the IPv4 from the RAK7249?

Hi @rowanb If your gateway is behind a router, it is normal for DDNS service(web) to catch the IP of your network device. You may need to set up forwarding or DMZ in your router. Does your Gateway is with dynamic IP or it is behind a router?

i was planning to have the 7249 as a remote stand alone device with only a 4G mobile connection.

it is currently running off Telstra network in Australia and is obtaining a network IP.

This is strange. Did you add the credentials to the gateway DDNS service first, prior to the update of the DynDNS IP?

Also can you check with your Cellular service provider that the inbound connections are allowed for your sim card?

Hi Todor. i did create a new hostname at noip.com who ive used previously to access a device behind my router. i was able to key in the IPv4 address listed in the 7249 cellular page and it connected through to the 7249 dashboard. it seems that the cellular connection works through anothe DDNS service when i manually put the IP address in.

Hi @velev

With regards to connecting to the 7249 via it’s over LTE, I have the 7249 broadcasting it’s WAN it’s IP to No-ip.com and I can see on its website that is has received the 7249 WAN IP. However when I use the hostname or even the WAN IP of the 7249, I cannot connect to the device.

I currently have the 7249 WIFI in ap+client mode for convenience, does this affect its ability to simultaneously have WIFI and WAN connections?

Or is there possibly a firewall issue stopping the connection?

Also I have confirmed the 7249 has a connection to the internet via LTE and am running successful LoRa connection to TTN over LTE

Thanks

Hi @rowanb can you check with your Cellular provider that the inbound connection to this SIM card is allowed?

Hi @velev, i haven’t been able to get any information out of my cellular provider. Hunting around forums in general it looks like by default most SIM cards do not allow inbound connections, does this sound about right?

Have you heard of any providers in Australia that would provide SIM’s for this purpose?

I cannot say for Australia, here in Europe, we have such options with some Cellular plans. And you can always ask for a real IP and inbound rules. For some fee of course. You can check some IoT providers like hologram.io they provide such access.