RAK7249 LTE issue

Recently purchase lora gateway 7249, and tried multiple sim cards for LTE but i always get the same response.


During this test modem was not connected to ethernet and wifi . It was working in AP mode . Please clarify how it should work in LTE .
And
is it possible to use the LTE and access the wifi internet on external devices via AP mode of 7249

RAK Technical team, would you please reply or provide some documentation to solve this issue . Is it still under development?

1.power off your device, insert SIM card, power on your device.
2.from this picture, i find you didn’t set APN,please set APN of your card provider. then, restart your device.
3.if all of above is ok,the device now works on LTE.

LTE mode and wifi Client mode cannot work at the same time.
if you want LTE mode and wifi AP mode, you should do as follow:
firstly,make sure your device work on LTE mode.
then, set AP mode as wifi mode, and set wifi ssid ,etc.

Thanks, @Nicholas for this solution. Actually, I am also searching for the same solution for my LTE modem, now I will try to follow these given instructions.
One thing please confirm that is client mode also called bridge mode?

Tried the same changes @Nicholas , I disabled the wifi interface and access the device over ethernet . Since i am using salt simcard in Switzerland , so entered the APN as “internet” and user,password entries kept blank. After saving all settings reboot the modem but the result is same it does not connect on cellular interface at all.

Are you sure your SIMcard APN is internet?

Yes @Nicholas sure about the APN, since with the same APN “internet” works on my phone and on another 4G hotspot device also. My gateway is already connected to internet via ethernet interface, and wifi interface was disabled, will it connect on cellular services with these settings. I believe it should show alteast the network name on dashboard. But nothing it remains same as screenshot shared in my first post.
Please suggest solution for this, or shall i change another telecom service provider if this may help.

can you please send your config to me.

董巷
Mobile: +86 18146804729|E-mail:[email protected]| QQ1165798730

深圳市瑞科慧联科技有限公司 Shenzhen RAKwireless Technology Co.,Ltd.
深圳市南山区桃源街道平山一路新视艺创客公园B栋506室
Website: www.rakwireless.com | 微信公众号/官方微博:RAK瑞科慧联
Twitter: @RAKwireless | YouTube:RAK YouTube Channel

Hi @Nicholas, mailed you the config file please check

Hi @vikram,

Mine does the following here in Bulgaria. I insert the card. No APN, no user or password, everything is blank. As a matter of fact is was set to work in AP mode even before inserting the card.
I plug the ethernet cable it works. I unplug it it keeps working over the LTE. It get the address via DHCP for the Cellular and it is displayed in the overview page. Maybe it is due to my carrier, however have you tried to leave everything blank?
Can you share what firmware version you are using. I am using:

Firmware Version 1.1.0037_Release r159

Regards
Vladislav

Hi @vikram,

After further testing my RAK7249 works flawlessly. Leaving the APn empty and well as filling in the APN of my provider results in the Gateway acquiring an IP address and forwarding packets.
Could you please try leaving the field blank, or trying “Internet*” as the APN name.
Perhaps you have solved the issues in the meantime ?

Regards
Vladislav

Hi @Hobo,
I could not solve this issue yet , i unplug the ethernet but status remains same. It does not connect via LTE.

I have tried with Salt and MBudget Sim cards in Switzerland, but no success. I always get the same status as above.
Yes my firmware version is same as yours : 1.1.0037_Release r159

You are trying to update the firmware.

Yes @Nicholas i updated it today morning to the latest 1.1.0040_Release r167, but lte is still same. Its not working.

You’d better take a photo of the firmware of your gateway to me, so that I can find the problem for you.

@Nicholas here it is

You need to photograph your hardware connections.

@Nicholas Hope this helps

Hi @vikram,

Sorry for not solving the issues already. Could you please update to the latest version and post the logs after. We are working on it, you have not been ignored. It is simply the fact that we can’t replicate the issues, as all SIM providers we have at our disposal seem to not cause this problem.
Please use the link and let me know how it goes:
https://downloads.rakwireless.com/en/LoRa/DIY-Gateway-RAK7249/Firmware/

Regards
Vladislav