RAK7249 WiFi client

Cannot establish RAK7249 as WiFi Client

Setup: RAK7249 LoRa gateway

LoRa® Server: in-built LoRa server

Details:

My RAK7249 is located in a barn. Co-located is a Linksys Lapac1700 access point with Ethernet (PoE) cabled back to the router in the house. The Linksys access point works perfectly facilitating cellphone access to broadband from within the barn.

Given the RAK7249 WiFi default is AP Mode, by locating a laptop next to the gateway, I can access 192.168.230.1 through connection to SSID RAK7249_XXXX.

I want to change the RAK7249 AP Mode to Client Mode ie client of the Linksys Lapac1700, so I go to Network > WiFi. I select Auto channel. I select client mode. I select really make change. The system says that it is making t he change, but site there for ever, it never stops “making the change”

I do a factory re-set, go through it all again, but this time I select “client + AP mode”. Select “really make the change”. A new dialog box comes up inviting me to scan or type in the client SSID. “Scan” sits there forever and does not find the Linksys AP.

Start again. Factory Reset. This time, it Type in SSID “Barn”, encryption, and password. Again, sits there for ever.

Bottom line, can’t set RAK7249 to WiFi client mode.

There may be a complicating factor. I normally operate the RAK7249 via RJ45/Ethernet on the RAK7249, however, I recently unplugged the RJ45 plug from the 7249 and the the RJ45 socket came off the motherboard in my hand. I’m trying to connect via WiFi client to the Linksys AP until such time as RAK Wireless replaces the board under warranty.

Any help would be gratefully appreciated. Thank you.

When you make that change, the wifi would cease being in AP mode, and the laptop would lose connection to it.

If it actually connects, and you can get a table of clients from the Linksys box, then you might be able to connect to the gateway’s web console using the newly assigned IP address on the Linksys wifi network.

There may be a complicating factor. I normally operate the RAK7249 via RJ45/Ethernet on the RAK7249, however, I recently unplugged the RJ45 plug from the 7249 and the the RJ45 socket came off the motherboard in my hand.

This sounds like the real issue. Normally if you wanted to configure the gateway for wifi, you’d do it while your laptop was connected to it by ethernet.

Thank you. Re your second point, I understand that, but the JR45 broke off so that was the end of my Ethernet access so no longer able to make that change from my laptop from inside the house. Indeed, that’s why I have resorted to the WiFi connection.

On your first point, I understand that too. That’s why I have to do a factory reset each time I want start over with configuring the WiFi in the RAK7249.

I think I’ll pursue the “table of clients” in the Linksys AP and see how I go.

Cld the firmware be corrupted by the RJ45 coming off when the RAK7249 was live. Should I try re-loading the firmware?

Thank you for your help.

No, and each time you’ve done a factory reset you’ve wiped out anything that would have ended up changed

Hei you guys,

You are actually both right to some degree. IF you only go into Client mode what Chris is saying is very true, however in AP+Client you should not loose the AP thus, it will be both connected to the WiFi via its newly assigned IP and you could also access it again via the AP if you wanted.
I have been playing with a couple of gates over the weekend and have noticed the same behavior, whenever I involve Client mode the gateway locks and needs to be factory reset.
I was just about to report the bug to the Firmware team, so there is definitely something there I believe.

Regards
Vladislav

Hello Chris, Vlad

I guess I Cld never say that with confidence because the RJ45 socket came off the motherboard so I don’t know if that did other damage.

However, I’ve spent the last hour or so trying every permutation and combination of AP, Client, AP+Client but to no avail. And that requires a factory reset every time, so big waste of time.

The thing is that yesterday my approach was “linear” in that I chose “client” because that’s what I wanted to set up. Nothing happened but for the hour glass spinning for 10 minutes. I had no preconceived idea as what the screen might do or not do next. So factory reset.

This time I chose “client + AP”. I figured that it meant both, simultaneously. Why I wld want that, heaven knows. I tried two options: “save the change” and “really change mode” in both orders - factory reset every time.

On one occasion a dialogue box came up offering to scan for the access point. I chose scan. It went in and on doing nothing. I typed in SSID “Barn”, selected the appropriate encryption, and entered the password. As you wld expect I lost wifi access to 7249 but Cld not access 192.168.230.1 from the wider network.

I only achieved that dialogue box “scan” once and have not been able to reproduce that again

I noticed that the relics of the RJ45 might have been contacting. I made sure that they weren’t and did it all again. Nothing.

Once I connect to the 7249 in AP Mode, I can execute all of the menu and make all sorts of changes eg change “built-in Lora server” etc and the changes take effect. I can select bands. I can add a concentrator.

Don’t know whether that helps but that has been my experience. Guess I have to be patient and wait for production delays to get a replacement mother board.

Regards

Ref this quote from the documentation -

“Client:
Choose this option to use Wi-Fi as a backhaul for the Gateway. You need to manually enter
the SSID, Encryption method and the Key itself. Note: Make sure to click the “Switch mode” button first in order to input the corresponding parameters, before saving and applying the changes.”

I have upgraded the firmware in my RAK7249. I have tried to set up the WiFi Client as per the quote above “in order to input the corresponding parameters”. That dialogues box never appears.

We have same problem with RAK7240. Impossible to connect using wifi client.Any suggestion? Any firmware update? Thanks for feedback.
Luca

Hello @lmiot ,

As I asked in my email, can I have a little bit more information it seems like you problem is a bit different?

Regards
Vladislav

Hello Lmiot, Hobo. I’ll try and do this from memory having done a few times now. I think the issue is in timing.

Bring a laptop with WiFi enabled close to the RAK7249.

select RAK7249_4ECF … or whatever your’s is. Go to your browser. Enter the RAK7249 IP address: 192.168.230.1. enter the password “root”.

Go to the WiFi menu. Select network > WiFi > Radio > Mode > “Access Point + Client” > “Really change mode”. Don’t select solely “Client”. Select “Access Point + Client”.

The top left corner of the screen will show a “timer” rotating, embedding the changes. It will rotate forever so intervene. As a result of the change, you will have lost WiFi AP connection to the RAK7249. Wait until RAK7247_4ECF next appears on your laptop as an available network. This takes a few minutes. You must be patient.

When it appears, go through the above logon procedure again When you get to “Radio” you will see an additional layer/conversation box at the bottom of the screen called “Wireless Client”. Type in the client name under ESSID or press scan and make a selection from what it comes up with. I’ve done it both ways: tell it the name of the client or wait … which may take a wee moment, and then select from the list. Accept its encryption or type in your own. Put in the password/key. Select “Save and Apply” in the bottom right hand corner.

Wait for the changes to be embedded and the new client/AP/ethernet connection to be established.

Turn off the laptop WiFi. Connect to the router via ethernet. I don’t know how you do the next bit: you go into some sort of “config” command in windows on your laptop and look for the IP address of the RAK7249; I use “Advanced IP Scanner” to get the IP address.

Go into your browser, type in the new IP, eg 192.168.1.227 and the RAK screen/logo will appear.

The key issues are:- once you make the initial change “Really change mode” your laptop/RAK7249 WiFi connection is dropped but you don’t know that because the RAK7249 screen on your laptop remains the same. You have to give the RAK7249 time to absorb the changes and then re-establish itself as a WiFi network. That can be quite a long time, a couple of minutes or so… Then you re-establish the WiFi connections and enter the details of the ethernet client. You then have to wait for those changes to be absorbed and the client/AP/ethernet relationship to be established. Thirdly, find out the new IP address of the RAK7249 and enter it into you browser. … and it will work like a charm.