RAK7258 LTE ver - No Cellular setup option

Hi just powered up my RAK7258 and then did a firmware update to
1.1.0062_Release r202 as I want to test Basic Station to TTI v3.

After upgrade the Status page seems to have regressed.
I no longer have the nice graphics at the top of the page as per https://doc.rakwireless.com/rak7258-micro-gateway/status-page

But the real bummer is I have no option to setup Cellular under the Network tab. And yes I did order the LTE version.

Help please


Hei @iiLaw,

The r202 has pretty much the same overview page:

This is mine. As for the LTE setup you can see it is there also. Not sure what happened, perhaps the firmware got messed up somehow, can you make a screenshot like the one I made and share it. It could be that tou also got a non Cellular unit perhaps?


Hi a reboot brought the status screen back to current but still no cellular setup.

My order

Hei @iiLaw
OK any chance you SSH into the Gateway and check if there is a wwan0 interface (ifconfig command),
Or you can open up the case and check if there is actually an Quectel soldered to the board:) Just to make sure this is not the issue :slight_smile:

Vladislav thanks for being on support so late :slight_smile:
I will try this tomorrow I’ve had a hard day and not functioning too well !!


Do that and lets’ see what we can do after.
No need for thanks, remember what is late for you might not be for someone else, RAK has team all over the globe.



Hei @iiLaw,

Interesting seems like there is the LTE antenna inside, so just to make sure can you look under the Concentrator to see if the Modem is actually soldered there?
I suspect it is there, which makes this even stranger.
I know this is a dumb solution, but try flashing the firmware again, just to make sure.
If this fails we shall have to escalate this to someone more knowledgeable.


So be clear I’m undoing the two screws on the concentrator.
To look at the cell modem underneath?

BT the GW was dropped in transit the above image was sent to Nancy.
As the screw was rattling around so I put it back and asked to test.


Hei @iiLaw,

Right, might be that something got knocked loose, solder cracked, who knows. But yeah unscrew the two screws and check, just to satisfy my paranoid nature :slight_smile:

We have had gateways fail, but never like this where the LTE is the only issue.


@Hobo Ok LTE module is there and did a FW re-flash still no Mobile setup!

@iiLaw well shucks.
Let’s see if @Yutao can help.
Maybe he will have a solution as I unfortunately do not have one atleast as of now.

ok thanks for your help so far.

BTW I tried Basic Station to TTI v3 couldn’t get the GW to connect.
I will try TTN tomorrow any idea when doc’s for setting up CUPS will be produced?

You can ask @velev, he will be the one making it so he will give you the most accurate prediction :slight_smile: I can only speculate.

I think the LTE has been disabled in software.

So Could you send some commands via ssh to enable the LTE function?

Login in the GW via ssh with user name: root password: root

and then send comands as below:

cd /tmp && einfo upload e

sed -i ‘/LTE_MODULE/s/0/1/g’ e && einfo download e

rm -rf /overlay/*


After reboot it will be enable the LTE function.

any question please let me know .

@hairui thanks this got things going.

Some general cell questions
WAN fail-over: assume GW tries eth0.2 then failsover to wwan0 (cell)?
How/can the cell data connection choose between: PPP || QMI ?
How/can the cell select authentication method: CHAP || PAP ?

Feature request can the cell status display the following
Data connection: PPP/QMI
Service: 2G/HSDPA/LTE etc
Roaming: Yes/No
Tower: 299A168

Also is there a way to configure Firewall to allow access to AP Master br-lan ( but not to wan? Eg connect to GW AP Master via wifi to monitor whilst GW is connected via cell wwan0?

Why? if FW Lan >> Wan [input] set to Accept then my Laptop chugges some 200mg per hr on my m2m sim. If I set Lan >> Wan [input] set to Drop then I can’t connect to AP Master br-lan (


Hi @iiLaw You can use BasicStation(LNS) with TTN. See here https://www.thethingsnetwork.org/forum/t/setting-up-basic-station-protocol-on-rak7240-and-rak7249-industrial-gateways/37011
For deploying the V3 stack… CUPS will take some time… Maybe next month. :smiley:

Thanks Hi I tried that with TTI v3 but wouldn’t work

And yes I did change the cert to that needed for eu1.cloud.thethings.industries
Thing is TTN is use v3 Gateway server so expected it to work.

Will try again at some point