RAK7258 - send MQTT packets to ActiveMQ 5 'classic' broker

you can help me to configure RAK7258 for this architecture:



but the broker no receives anything

thank you

Presumably you are not trying to run a LoRaWAN network server on the PC, or build some other custom network protocol stack - presumably you simply want the PC to obtain messages after they are validated and decrypted by a network server.

The “out of the box” solution for this would be to reset your gateway to factory configuration, enable the built-in network server, and register your node with that.

Once you can see messages showing up in the gateway lora server’s own information screens, the simplest way to get your data would be to point your PC at the gateway’s own built in MQTT broker, rather than using an external one.

If you wish to redirect the built-in network server’s output to an external MQTT broker, you can do so, but you must be extremely careful to redirect only the application-level output. DO NOT touch the packet forwarder settings, MQTT bridge settings, or gateway-facing MQTT settings of the built in server, as if you do any of those things you will break the path of raw traffic, and cease getting any messages at all.

Ultimately speaking, the “correct” path for anything but installations isolated from any Internet connectivity is to run the network server in a traditional or cloud server, where it can accept feeds from multiple gateways, not just one. You’d then claim your data via a supported output mechanism, such again as an MQTT subscription. TTN offers a shared community setup for this; for a private network you can use Chirpstack (which is the later evolution of the built in server software in the 7258) as hosted by Chirpstack or RAK, or you can follow Chirpstack’s instructions for installing your own instance on a cloud or conventional server. In theory you could even run it on your PC, though it should be a machine which is consistently up.

First of all thank you for your reply, for a second I change the architecture

(MQTT.fx I only use it for subscriber testing)

Reset the firmware to its initial state
Backup / Flash Firmware → Reset to defaults: Perform reset

Enable the built-in network server
LoRa Network → Mode: Network Server
Save & Apply

MQTT.fx, connection

MQTT.fx, subscribe MQTT topic gateway

EndNode traffic

Node register

>>>But LoRa Nodes is ZERO<<<

>>>no Packet<<<

>>>and no traffic in LoRa Network Server Status<<<

How to register the node ?

thx cm

You’ll need to follow the instructions for that; I don’t have that setup here, but be especially careful to make sure that you get the device address and sessions keys right between the server and your node for ABP, or the device EUI, application EUI and application key right for OTAA.

Also go back into that earlier packet forwarder screen and make sure it’s pointed at the MQTT for built in server; I though that was the default, but again I don’t have it here to test.

Also make sure your follow setup instructions to get the right bandplan configured and public/private network mode matching what your nodes do.

Once you have the node traffic appearing decoded in the server, the next issue is that the decoded results are on application/ MQTT topics, the gateway/ topics hold only the raw traffic between gateway and the server.