RAK7268 Firmware version WiseGateOS v1.2.1 checksum mismatch

Issue: RAK7268 Firmware V1.2.1 Checksum mismatch

Setup:RAK7268

LoRa® Server:

Details: I downloaded the “RAK7268_Latest_Firmware” file and when loading it into the RAK7268 the checksum calculated does not match the checksum in the enclosed checksum.txt file (and the firmware version in the checksum.txt file is incorrect). Can you please confirm the checksum for the latest version firmware: WisGateOS_1.2.1.bin?
Thanks.
Brendon.

I have the same issue too

Refer Checksum file content below and I could see wrong file version WisGateOS_1.1.2.bin instead of WisGateOS_1.2.1.bin. Looks like some confusion or something wrong.

ea82c6220ca5448a9dee10b8f9bc312c  WisGateOS_1.1.2.bin

This firmware is broken as I could see after flashing, system is failed to expose UI and below is the error. So, I had to reset the gateway.

/usr/lib/lua/luci/dispatcher.lua:537: bad argument #1 to 'pairs' (table expected, got nil)
stack traceback:
	[C]: in function 'pairs'
	/usr/lib/lua/luci/dispatcher.lua:537: in function 'createtree'
	/usr/lib/lua/luci/dispatcher.lua:201: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:168: in function </usr/lib/lua/luci/dispatcher.lua:167>

Please advise