Rak7268C no option to use EU433?

Hello guys,
for some reason i do not see the option to choose EU433Mhz under channel settings. can someone please point me to how i can configure the gateway on this frequency?

Gateway Name: RAK7268C WisGate lite 2
Firmware version : 1.3.1
Tested with Local Network and TTN Basics with the same issue, i only see three frequencies to choose from:

@JayjJay

As far as I know we do not offer a 433MHz model, are you sure yours is one?

Regards
Vladislav

Hello @Hobo
Thanks for the reply, maybe i miss understood things! To me i thought the semtec chips frequencies were software programmable, so they can be interchangeable and just require the right antenna for each frequency. Isn’t that the case?

Moving on to another question:

  1. My customer has a specific request to only use and limit the use of the EU868 frequency from 869mhz to 870mhz can you please tell me how to program this on the gateway?

Basically 868mhz to 869mhz are forbidden for the moment and not allowed to transmit on those.
Thank you!
Jay

@JayjJay

Yes and no, some are, some are not. also bands like are very far apart require a redesign, you can’t have the same filters, they can’t be tuned for both frequencies as they are too far apart. Thus you might have the same chip inside, but the model is different, cause other components are.
The frequencies in the RU868 are standard, so once set he should get the right set. If for some reason he needs something very specific, you can configure them separately, via the same interface page you showed.
Can you share the specific channels he needs to use, I will check them out for you.

Regards
Vladislav

Thank you for the explanation! I appreciate the offered help on the second question:
Basically the client said to not use the following frequency: 868mhz to 869mhz as they have something using those!

And i should only use this:
869Mhz to 869.4Mhz at 25mw p.a.r with any bandwidth
869.4Mhz to 869.65Mhz at 500mw p.a.r with any bandwidth
869.5 Mhz to 870Mhz 25mw P.a.r with any bandwith.

So how do i program that on the gateway and on the node! Because for the node side, i’ve tried to play with numbers in EU868.h from Semtech but the gateway doesn’t pickup the traffic so im sure im not doing this right ?

OK, this might not be possible, you seem to want to have 1 channel that is 400KHz, one that is 250KHz and one that is 500KHz.
While you can set the channel center frequency, you can’t set the bandwidth other than the standard 125KHz, with the exception of the LoRa Std channel (125, 250, 500)
What I can think of is instead of having these 3 channels you can have the 8 channels of 125KHz grouped so you have one that is 500 (4x125) one that is 250 (2x125) and another 250 (2x125). This will fill the total 8x125 that the concentrator support. If you want more you need to get a gateway wit 2 concentrators for a total of 16 channels.
The center frequency you can set here:

Make sure to turn the “Conform to LoRaWAN” option off in order to be allowed to set the frequencies manually.

Regards
Vladislav

Thanks for the updates,
but can you please share more specifically what i need to write on each channel? this is the screenshot of my channel plan.

and i still see the transmission on 868 where it should be between 869 and 870

As I said you can’t have exactly what you want, you need to pick the central frequencies for your channels first.
Make sure you know these to begin with.

can you suggest something i can try as i don’t really know how to proceed from here…

i did try these but it didn’t work, i see nothing on the Lora packet logger

and to make testing easier i hard changed the region file directly like this (changed 8 with 9 in the 868100000 to 869100000 just to see if it works but no.

and my node is transmitting on the frequency set on LC1 to LC3 as shown below but the gateway doesn’t pick anything up:

image

another update: after changing the Lora Network Settings from Basics Station to Network Server, it started to see the join packets: but only join requests the accept requests are never received by the node I’m sure they are not sent on the right frequency, as i have yet to find where to set this setting:
Edit: now it works but barely, after adding an application and adding the device the join completed but only after many tries, for some reason it keeps timing out on the RX node side. so i know that i am on the right track… :slight_smile: just need to tweak this so it is 100% and that’s where i need an experts help.

putting it back to Basics Station with TTN the Lora packet logger sees nothing again… is there a reason?

i think we have a bug.
anything i set on the Channel Plan for example, has no effect when i choose Basics Station under Lora network settings… for some reason it always defaults to the standard frequencies that are part of the chosen template which in my case is EU868

so the above has no effect when used with the below:

is this a BUG?

OK lets make this easy:

  1. What LoRaWAN server are you using - do you want to use the built in one (Network Server) or a 3rd party one (Basic station)
  2. What is the network channel mask your end node is using, give me the center frequencies it is using so I can tell you how to configure a matching set in the Gateway.

Thank you for your continued support.

  1. What LoRaWAN server are you using - do you want to use the built in one (Network Server) or a 3rd party one (Basic station)

Ideally i would like to make it work on both, but for started let’s do the Basics Station with TTN as that’s the one where i cannot even make it work.

  1. What is the network channel mask your end node is using, give me the center frequencies it is using so I can tell you how to configure a matching set in the Gateway.

i’m writing the firmware of the node so all those parameters are configurable, it is based on : semtech’s reference code found here https://github.com/Lora-net/LoRaMac-node/blob/master/src/mac/region/RegionEU868.h.
As far as the requirement i’ve received are based on the countries law, which apparently for the time being is restricting the use of the full LoRa EU868 spectrum until end of this year, as shown in red below:

which basically forbids the use of 868 - 869 Mhz, but they leave everything between 869-870Mhz exploitable as shown above. so that’s where i would like to configure both the node and gateway to use so we can be compliant with the law.

we know that it’s a bizarre circumstance, but the countries regulators told us that those frequencies are still being exploited by certain organizations and they are working with them to clear them for public use since they are supposed to be unlicensed, so we just have to tweak our setup until the full Lora spectrum is usable again.
So for the node channel mask, you tell me what i should use to be complaint with the above law.
my guess would be the following, but please correct me if i’m wrong:

 #define EU868_LC1                               \
     {                                           \
         869100000, 0, {((DR_5 << 4) | DR_0)}, 1 \
     }
 #define EU868_LC2                               \
     {                                           \
         869300000, 0, {((DR_5 << 4) | DR_0)}, 1 \
     }

 #define EU868_LC3                               \
     {                                           \
         869500000, 0, {((DR_5 << 4) | DR_0)}, 1 \
     }

i hope this makes sense.

You can’t use a custom frequency plan with TTN, you’d first have to convince TTN to implement a frequency plan appropriate to the country in question. Just programming your gateways and nodes to custom frequencies won’t work, because the server will see wrong uplink frequencies and/or try to add the other standard ones.

If you want to go custom you’ll need your own server instance.

Ah thanks for pointing this out, absolutely true, I was just thinking of giving you the frequencies with a 125kHz bands. The server end I can’t do much about you as it is not officially supported we have not considered or implemented it as a solution.
If you look at the image you will see what field and data you need to fill in to make the channel plan fit your 3 channels.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.