RAK7289CV2 | Delays in Consecutive Downlink Transmissions

  • Objective : I am trying to achieve two or more quick consecutive downlink transmissions (i.e., sending 2 or more messages within a second).

  • Device Setup: The device is configured as a Class C device operating in the EU868 frequency band. For efficient communication, I have set a high RX2 Data Rate in the gateway. The preferred data rates are DR6 (SF7BW250) and DR7 (FSK).

  • Observation : Despite sending messages at intervals of 1 second or less to the integrated MQTT server, there appears to be a consistent delay of about 2 seconds between the receipt of two consecutive messages.

  • Testing Scenarios :

    • The delay persists regardless of the data rate and payload size used. Even with faster data rates (e.g., DR6 or DR7/FSK) and payloads as small as 1 byte, the gateway does not transmit downlinks faster than with this approximate 2-second interval.
    • I tested this using two different frequencies: 868.3 MHz and 869.525 MHz, the latter of which lies in the ETSI frequency band allowing for 10% duty cycling.
  • Gateway Packet Capture: The attached image ‘gateway_packet_cap.png’ illustrates a scenario where I attempted to send 5 packets in rapid succession (with an interval of 500 ms between each) to the Gateway’s MQTT Server. However, as shown in the screenshot, the gateway’s actual scheduling of these packets deviates from the intended rapid sequence. This results in a consistent and observable minimum delay of 2 seconds between each transmission. This behavior is contrary to my intended use case and appears to be a limitation in the gateway’s scheduling mechanism.

  • Gateway Logs : Upon inspecting the gateway logs, I encountered the following error message, which seems to hint at the gateway rescheduling the transmission:

    Wed Jan 24 16:05:25 2024 daemon.err nwkSrv[7255]: nsMoteSheduleClassCTx : 021f5525 prev downlink have been scheduled. Waiting for reschedule

The issue stemmed from the default scheduler settings of the WisGate’s built-in network server (as hinted by the error message in the log).

Apparently, the built-in network server of the WisGate gateway had default settings causing a minimum 2-second interval between downlinks. I haven’t found any interface that allows adjustment of the scheduler interval settings.

Therefore, my workaround here was to Setup an External Network Server:

  • I set up a ChirpStack Network Server with custom downlink scheduler configurations.
  • Linked this server to the gateway by changing the Work Mode to ‘Packet Forwarder’ and using the MQTT Bridge Protocol.

This solution bypasses the limitations of the WisGate’s built-in network server and offers greater control over downlink scheduling such as rapid consecutive downlinks without the 2-second interval limitation.

I hope this helps anyone facing similar issues with their LoRaWAN deployments.

Best regards,

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.