RAK811 Error: 99

Hi Team,

Greetings and Good day, trust you doing good.


I have provisioned one RAK811 LoRaWAN device on TheThingsStack V3, the parameters that I have used for the RAK811 are as follows:

As you can see from the snapshot below the RAK811 is not able to latch/join to the LoRaWAN network using the “at+join” command, it’s after the 4th try that the RAK811 was able to join the network with “OK Join Success”.

The Network Layer has been set as follows:

can you please advise what is wrong with my setup??




Many thanks for your help,
Bet Regards,

Hi @Avishek ,

Can you check your channels which are open and close using this command at+get_config=lora:channel?

When joining in EU868, channels 0,1 and 2 are the joining frequency so all must be off.

You can use this command to turn off other channels that are on at+set_config=lora:ch_mask:X:Y where X is the channel number and for Y it can be 1=on or 0=off.

Let say channel 3 is open and we need to close that, you will use the at+set_config=lora:ch_mask:3:0 command.

Hi Carl,

Thanks for your swift response and continuous support.

you can refer to the snapshot before turning off Channels 8,9,10,11,12 using the command at+get_config=lora:channel to query for the available channel

After turning off Channels 8,9,10,11,12 using commands that you mentioned

I am now able to latch/join the LoRaWAN Stack v3 right away :+1:

Indeed many thanks for your help in resolving this issue :+1: :+1:

In addition, can you please confirm, once “Join Success” to LoRaWAN Stack v3, I should turn ON Channels 8,9,10,11,12 to allow uplink traffic right?

Many thanks,
Best Regards

No need to turn on the channels again.

It will be automatically set once you successfully joined.

You can check again the channels if you want to confirm :+1:

1 Like

Hi Carl,

Yes, indeed you are right!! :+1: :+1: :+1: :+1:
Just now, I did the testing you can refer to the snapshot below.

you are a genius man!! keep it up!! :wink:
Best Regards,

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.