RAK811 - Firmware v3 - Baud rate change

Hi @shayagmon,

We’ve fixed this issue and released a new version firmware, please download from here:

Thank you very much ! Confirmed that it is fixed.

Even i had the same problem with the app_key input on 9600 bps… Confirmed that the above problem is solved…

But now a new problem arises!

After sending data (at+send), the device goes into sleep mode (Go to Sleep).
When we try to send data again, theirs No response after that. A Wake Up message is shown. Further sending or entering any other AT command does not given any reply.

Kindly help with the same…


Hi @jithins,

Yes, this is an issue, and we’ll fix it ASAP, then release a new firmware in 2 days. Please wait.
Thank you!

Hi @Fomi

Thanks for acknowledging the same… It is a big bother for developers if the code that worked earlier breaks down after an upgrade… Do try to fix the issue soon… Thanks a lot…


Hi @jithins,

We’ve fixed this issue. Please download the latest firmware:

1 Like

Hey @Fomi

Thanks… Confirm that the issue is resolved.

So now the device goes to sleep immediately after sending. If we send again, then the device wakes up. Only on the next send, does it send again.

Or else, before every send, we wake the module up by using the at+set_config=device:sleep:0 and then send.

Is this correct? It would be good if this is mentioned in the brochure… Thanks a lot.

Attaching screenshots for anyone who needs help with the same.

Jithin Isaac

Hi, @Fomi

I’m using RAK811 module connected to a host microcontroller via AT commands.
My host microcontroller is capable to send AT commands maximum at 9600bps.

In earlier version V2.0.3.4, I have changed baud rate to 9600bps by this command and worked.

Now upgraded to the latest version V3.0.0.11.H
I want to change baud rate to 9600bps again for the host microcontroller is able to send LORA AT commands (e.g. Join, Send, Sleep…)

I have tried that command for the latest version;
and the response is;
OK,The UART1 baud rate switch to 3.

From my microcontroller or when test PC-USB on the Wisnode Lora Module, I can not send LORA AT commands at 9600bps.

Then I tried also that;
and the response is;
Current AT uart work mode:normal mode

But It doesn’t work at 9600bps, but it still works at 115200bps.
What should I do ?

Hi, @Fomi
My custom microcontroller board has a firmware update connector for RAK811 smd module.
After firmware updated, I want uart at 9600bps configurated as well to be save non-volatile on RAK811.
My host can never send to uart at 115200bps for runtime configuration.

Yes, I want to use V3.0.0.11.H default at 9600bps and What should I do ?
Thank you

I’m very sorry reply so late.Yes,this is a vrey terrible bug.we will fix it quickly,and you could update fimeware to V3.0.0.12.H.

1 Like

Hi, @leopold
Thank you for the response.
I wait for V3.0.0.12.H

Yes, once baud rate has been changed that must be saved non-volatile.

1 Like

im using wisnode with arduino uno as a shield.

i have tried out the following codes.

and changed the baud rate to 9600 by the command


but im not getting any response
when i run the code the commands that are passed to the wisnode will be printed


my firmware version is
Firmware Version: RUI v3.0.0.12.H

what should i do next ?

Hi @sheminanto,

I think the UART you are using may work in passthrough mode now.
You can use “+++” to change the UART to work in configuration mode firstly, and try again.

Hi @sheminanto

First "at+band=0 " is illegal instruction.
Don’t use Arduino board, directly connect to WisNode with micro USB, send instructions to see if there is a response.If no response,maybe you need modify uart mode to normal mode in @Fomi way.
If it is normal with micro USB directly,I guess you maybe use USB of Arduino board to monitor response,this method is wrong.You need use SoftwareSerial DebugSerial to monitor module .

only the first line is printing “startup”

can you please specify the full command

Don’t use Arduino board, directly connect to WisNode with micro USB, send instructions to see if there is a response?

im using arduino uno . did i need to remove those resistors of v1.2

i have connected wisnode as shield. and monitored the serilal out of arduino

can i get your contact info :

Yes,if the two boards are buttoned directly,you must remove resistors.
my email :[email protected]