RAK811 - Firmware v3 - Baud rate change

Hello all,

I managed to Upgrade firmware version from 2.0.3.0 => RAK811 Version:3.0.0.3.H successfully (I got RAK811 V1.2).

However, I got two requests:

  1. Is there a new AT Command guide becuase I see some of the commands changed and I need to update my Arduino code accordingly? (Example: lora. is added to some and at+join=otaa is changed to at+join simply).
  2. How to change the baud rate since it is now in 15200 after flashing the new firmware?

Thanks for helping out.
Best regards,
Zabeel (Cool_GuY)

Hi @zabeelr,

You can refer to the page for the new commands:
https://doc.rakwireless.com/rak811-wisnode-lora-module/configuring-your-rak811-wisnode-lora

As far as the baud rate, I can’t help, perhaps @Fomi will be able to assist.

Regards
Vladislav

Hi @zabeelr,

We’ve just released a new firmware V3.0.0.4 for RAK811 today, and in this version, you can customize baud rate freely by AT command.
The new firmware is here:
https://downloads.rakwireless.com/en/LoRa/RAK811/Firmware/
You can use it according to this document (including all AT commands):
https://downloads.rakwireless.com/en/LoRa/RAK811/Application_Notes/

Thanks @Fomi @Hobo for the information. I will try it this afternoon after work. However, 1 more question, to change uart baud rate, we use the previous used at command since in the new table there is no baud change command?

Thanks,
Best Regards
Zabeel

Hello,
I upgraded the firmware to the latest version 3.0.0.4 but when trying the command >>at+uart=9600, X, X, X it gives an error “The AT Command is invalid”.

Please help with the AT command.
Thanks & Best regards,
Zabeel

Hello,

I managed to get it work at baud rate 115200 with arduino and also work with ttn. It seems great.

I had to tweak the arduino code a bit and the class library.

Many Thanks for your help guys.
Best Regards,
Zabeel

That’s good.
Actually, you can use the following AT command to configure baud rate:

Hi, I had the same issue with baud rate, but I managed to connect to ttn after following quick start guide. However, I’ve not managed to make RAK811 work with Arduino- could you kindly share your approach on this.
Thanks
Kimogol

Hello @skim,
I am using the arduino nano with the Rak811. I connect the TX and RX (0, 1) from the arduino to the Rak811 TX and RX but inverse.

TX from Arduino to RX from RAK811
RX from Arduino to TX from RAK811

Then need to set the jumpers accordingly on the Rak811. That’s it.

I didn’t retry for arduino uno as shield after the firmware upgrade. I will need to check this.

Regards,
Zabeel

Thank you @zabeelr. I’m using Arduino uno and I’ll try if this works.

Hi Fomi,

Using wisnode v1.2 and new FW version 3.0.0.4.H managed to change baud rate to 9600
However, AT command: “at+set_config=lora:app_key:” can not be set at 9600
It does work at 115200 though.
Also “AT+join” does not work at any of the baud rates. Is it replaced by something else to start to join a network?
Thank you.
Shay

Hi @shayagmon,

This is very strange, I was playing with a RAK811 yesterday and at+join seemed to work fine. Can you try to enter the authentication parameters and perform a hardware reset after, it should star the join procedure automatically.

Regards
Vladislav

Thank you Vladislav for addressing this.
Did as you suggested.
Reply to ‘at+send’ is “parameter not found”.
After HW reset getting following, copy-pasted below.
I am guessing the “parameter not found” in last line is because of the at+join command not being accepted.
Note that I might have wrong authentication parameters. They are still not verified and I have not been able to connect yet to private lora network (not ttn).
" Selected LoRaWAN 1.0.2 Region: US915
Initialization OK,AT Uart work mode:normal mode, Current work_mode:LoRaWAN, join_mode:OTAA, Class: A
Parameter not found. "

Hi @shayagmon,

Reply to ‘at+send’ is “parameter not found”. I think you misunderstand the concept.

You need to configure the device to connect first, you can’t be sending data frames before this is done.

Parameter not found. "

This simply means that when the device tries to initiate the OTAA procedure, there aren’t valid:
dev_eui (Device EUI)
app_eui (Application EUI)
app_key (Application Key)

Those above need to be inserted with the commands below as per the values you have configured in the LoRa Server you are using in the application/device you have input there. Use the commands below, where XX is the values for your LoRa Server.

at+set_config=lora:dev_eui:XX
at+set_config=lora:app_eui:XX
at+set_config=lora:app_key:XX

Regards
Vladislav

Hi @shayagmon,

The AT command to change UART baud rate is this one:

Thank you for your replies. I will set the correct dev_eui, app_eui and app_key and then try again. I must have been using incorrect values for these before.
Best regards,
Shay

Hi Fomi,

Can you please confirm this:
Using Wisnode v1.2 and FW version 3.0.0.4.H can change baud rate to 9600 as instructed (successfully).
However, AT command: “at+set_config=lora:app_key:” can not be set at 9600 baud rate.
It works at 115200 but not at 9600.
Thank you.

Hi @shayagmon,

You can try to use “at+set_config=device:uart:1:9600” to change the baud rate to 9600.

Yes, the command to change to 9600 baud rate works but once at 9600 the following command does not work: “at+set_config=lora:app_key:”
Thanks.

Hi @shayagmon,

Oh, i’m sorry. We’ve confirmed this issue, and we’ll fix it today.