RAK811 has no response to AT command

I bought a RAK7258 in-door gateway and several RAK811 breakboards last month.

I tried flashing the RAK811 module with latest firmware found on RAK website: https://downloads.rakwireless.com/en/LoRa/RAK811/Firmware/

I followed the steps mentioned in user manual, flashed boot loader v3.0.2 and upgraded the firmware successfully. However, when I reset the module and send AT command through serial port, I got nothing. Some screenshot are enclosed.

Any help is greatly appreciated.

Further, I tried to use third-party serial port tools and found that every reset the module will send out 350 ‘0x00’ through uart1. And AT commands still got no response.

Hi @Shoulder,

According to the first picture you show, RAK811 works in the BOOT mode now.
You can use “at+run” to have a try, if it can work in the normal mode successfully, everything will be OK.
But if it still work in the BOOT mode, it means that you haven’t upgraded the firmware for it successfully, then you need to upgrade the firmware for it again.

My apologize. The first two response in the picture was produced after flashed boot loader, and I did not clear the display.
After upgraded the firmware, I could not see any response form the module. Actually, I just read out and checked the firmware running in the MCU, and can hardly find any difference with the boot-loader firmware, even the memory size. However, the boot-loader program can not run correctly anymore.

Hi @Shoulder. Do you remove the bootloader flash jumper? Can you give a screenshot from RAK serial tool after you reset the module and after you execute at+run command?

Hi @velev, Thanks for your apply.
Actually, I used ST-LINK Utility to burn the boot-loader firmware, so BOOT0 was always set to low.

Hi @Shoulder,

I’m sure that there is no firmware in your RAK811, only the bootloader running.
Please have a look at this tutorial and upgrade the firmware for your RAK811:

Hi @Fomi,

I’ve upgraded firmware follow the tutorial again and again, every time I got a “Upgrad success!”. I am really confused.

Hi @Fomi & @velev,

I finally resolved this problem by change the baud rate to 9600. However, all your documents mentioned 115200, is this a bug?

Anyway, thaks for all your help.

Hi @Shoulder,

Oh, i’m sorry for that. Yes, this is a bug, the default baud rate should be 115200.
2 weeks ago, when we dubug a solution using Arduino UNO and RAK811 (Wisnode), we find that, if the baud rate is 115200, there will be an issue between UNO and Wisnode. When we change the baud rate to 9600, everything is OK. I think the bug is caused here, and we forget to modify the default baud rate to 115200, really sorry for that!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.