RAK811 Lora does not send data for the region US915

Issue: In the region US915, it does not send data. Received the error ‘RAK811 response error 96: LoRa RX2 timeout’

Setup: Using in Jetson Nano board

Server: Using chirpstack

Details: I received the module RAK 811 Module (LoRa Node) and Antenna and made UART connection with Jetson Xavier NX module and executed the following commands to test, but it throws the error message “RAK811 response error 96: LoRa RX2 timeout”

rak811 hard-reset
rak811 version
rak811v3 -v set-config lora:work_mode:0
rak811v3 -v set-config lora:join_mode:1
rak811v3 -v set-config lora:region:US915
rak811v3 -v set-config lora:dev_addr:[mydeviceadd]
rak811v3 -v set-config lora:nwks_key:[mynetworkkey]
rak811v3 -v set-config lora:apps_key:[,yappkey]
rak811v3 -v join
rak811v3 get-config lora:status | grep ‘Current Datarate’
rak811v3 -v set-config lora:dr:2
rak811v3 -v set-config lora:confirm:1
rak811v3 -v send ‘Hello’

It also throws this error message sometime "RAK811 timeout: Timeout while waiting for data
"

Did you try once this module on this region?

Hello @rajaamp , welcome to the forum.

About your list of commands, after sending the join command, do you wait for the response from the RAK811 that it actually has joined?

at+join\r\n
OK Join Success

Can you check which channels are enabled with at+get_config=lora:channel\r\n?
If you are connecting to TTN, the channels 8-15 should be enabled, not channels 0-7.

On the server side, I guess you have setup the node as ABP device and have the same NWSKey and AppsKey there?

Can you see traffic on the gateway logfile?

I don’t know the Jetson Xavier NX module, but the way you listed the commands, looks like you are using a kind of library or application. Can you share some details.

Did you try to connect the RAK811 with a USB-UART adapter to a computer and tried to setup and connect over a terminal app?

I was using RAK811 on US915 before, it worked just fine for me setting the device over UART from my computer.

@beegee ,

Thank you for the prompt reply.

About your list of commands, after sending the join command, do you wait for the response from the RAK811 that it actually has joined?

at+join\r\n
OK Join Success
>> Yes, it was successful.

This is the response for at+get_config=lora:channel. Yes it is using the channel 8 for now.

[email protected]:~# rak811v3 get-config lora:channel
 0,off,902300000,0,3;  1,off,902500000,0,3;  2,off,902700000,0,3;  3,off,902900000,0,3;  4,off,903100000,0,3;  5,off,903300000,0,3;  6,off,903500000,0,3;  7,off,903700000,0,3; * 8,on,903900000,0,3; * 9,on,904100000,0,3; *10,on,904300000,0,3; *11,on,904500000,0,3; *12,on,904700000,0,3; *13,on,904900000,0,3; *14,on,905100000,0,3; *15,on,905300000,0,3; 16,off,905500000,0,3; 17,off,905700000,0,3; 18,off,905900000,0,3; 19,off,906100000,0,3; 20,off,906300000,0,3; 21,off,906500000,0,3; 22,off,906700000,0,3; 23,off,906900000,0,3; 24,off,907100000,0,3; 25,off,907300000,0,3; 26,off,907500000,0,3; 27,off,907700000,0,3; 28,off,907900000,0,3; 29,off,908100000,0,3; 30,off,908300000,0,3; 31,off,908500000,0,3; 32,off,908700000,0,3; 33,off,908900000,0,3; 34,off,909100000,0,3; 35,off,909300000,0,3; 36,off,909500000,0,3; 37,off,909700000,0,3; 38,off,909900000,0,3; 39,off,910100000,0,3; 40,off,910300000,0,3; 41,off,910500000,0,3; 42,off,910700000,0,3; 43,off,910900000,0,3; 44,off,911100000,0,3; 45,off,911300000,0,3; 46,off,911500000,0,3; 47,off,911700000,0,3; 48,off,911900000,0,3; 49,off,912100000,0,3; 50,off,912300000,0,3; 51,off,912500000,0,3; 52,off,912700000,0,3; 53,off,912900000,0,3; 54,off,913100000,0,3; 55,off,913300000,0,3; 56,off,913500000,0,3; 57,off,913700000,0,3; 58,off,913900000,0,3; 59,off,914100000,0,3; 60,off,914300000,0,3; 61,off,914500000,0,3; 62,off,914700000,0,3; 63,off,914900000,0,3; 64,off,903000000,4,4; 65,off,904600000,4,4; 66,off,906200000,4,4; 67,off,907800000,4,4; 68,off,909400000,4,4; 69,off,911000000,4,4; 70,off,912600000,4,4; 71,off,914200000,4,4

On the server side, I guess you have setup the node as ABP device and have the same NWSKey and AppsKey there?
Raj>> Yes, i verified already.

Can you see traffic on the gateway logfile?
Raj>> No, I dont have that access for now. I can ask my client if it is really required.

I am using the library - https://github.com/AmedeeBulle/pyrak811

Did you try to connect the RAK811 with a USB-UART adapter to a computer and tried to setup and connect over a terminal app?
Raj>> I was using serial communication with one of the UART port. It is working ok. I could reset the device and see the version number using the following commands. It means, no issue with the connectivity.

rak811 hard-reset
rak811 version

Based on the error, "RAK811 response error 96: LoRa RX2 timeout" so I need to specify the data rate for RX2 on the TTN/ChirpStack along with frequency for the same?

I am using ABP with class A.

RX2 is setup automatically in TTN, no need to anything on the server.

Setting up my RAK811 for US915, ABP and sending data:


Data is shown in Gateway log file:

Data arrives in TTN:

So it works with ABP and US915.

Two possible problems why you cannot see the data in the LoRaWAN server:

  • You are out of range of the gateway
  • The Python library

I would try two things:

  1. Go through the complete sequence with an USB/UART adapter from your PC and check if you can send data.
  2. Switch to OTAA join mode and see if you can join the server. If both node and server are setup correct, but it cannot connect, you might be out of range of the gateway.

The gateway you want to use, is it a public accessible gateway? Is it connected to TTN correct? Is the gateway shown connected in TTN?

I have checked the UART communication, it looks ok. Also I see message sent when there is a configuration “lora:confirm:0” but when I change it to “lora:confirm:1” then I see the RX timeout message. I do not see any issue till before. Please check the screen shot below and suggest me if there is any configuration required in chirp stack?

Gateway looks private. I have also requested our client to check the gateway logs since I do not have access to it. Meanwhile, can you please check my message and suggest something? Thanks in advance.

I am attaching another media since it does not accept more than one for me.

If you set the message to “Confirmed”, then the RAK811 expects an ACK from the server. **RAK811 response error 96: LoRa RX2 timeout means in this case that the server didn’t send an ACK or the ACK got lost.

There is no settings in Chirpstack or TTN required to send this ACK. It is handled by the server internally.

Do you see any error message in Chirpstack or TTN logs when this happens?

Without seeing the log of the Gateway, I cannot say what is happening.

Thanks @beegee.

I have sent an email to my client, I will check and come-up with the logs shortly. meanwhile, I have attached one more media of my profile settings. Please check and comment if there is any issue with that.

@beegee,

I see our gateway supports only the following FREQS. is that the cause of the issue? because channel listed above starts only from 8,on,903900000,0,3 to 15,on,905300000,0,3

0: # 902.3 MHz
1: # 902.5 MHz
2: # 902.7 MHz
3: # 902.9 MHz
4: # 903.1 MHz
5: # 903.3 MHz
6: # 903.5 MHz
7: # 903.7 MHz

if so, how can we change the frequency to 7 in RAK811?

US915 region is using channels 8 to 15 on most public LoRaWAN servers. So you need to change the frequencies on the gateway and not on the node.

But if you do not have access to the gateway, you have to change the frequencies on the node AND in the LoRaWAN server.

On the RAK811 you change the frequencies like this:

// Enable channels 0 to 7
at+set_config=lora:ch_mask:0:1
at+set_config=lora:ch_mask:1:1
at+set_config=lora:ch_mask:2:1
at+set_config=lora:ch_mask:3:1
at+set_config=lora:ch_mask:4:1
at+set_config=lora:ch_mask:5:1
at+set_config=lora:ch_mask:6:1
at+set_config=lora:ch_mask:7:1
// Disable channels 8 to 15
at+set_config=lora:ch_mask:8:0
at+set_config=lora:ch_mask:9:0
at+set_config=lora:ch_mask:10:0
at+set_config=lora:ch_mask:11:0
at+set_config=lora:ch_mask:12:0
at+set_config=lora:ch_mask:13:0
at+set_config=lora:ch_mask:14:0
at+set_config=lora:ch_mask:15:0

If using TTN, you have to set the frequency plan of the device to United States 902-928 MHz, FSB1. For other LoRaWAN server you have to check the documentation how to change the frequency plan.

@beegee ,

Thanks for the excellent support. I really appreciate it. After doing the configuration below, it started working. Note - I have not changed anything in LoRaWAN server since it already uses the channels 0-7.

// Enable channels 0 to 7
at+set_config=lora:ch_mask:0:1
at+set_config=lora:ch_mask:1:1
at+set_config=lora:ch_mask:2:1
at+set_config=lora:ch_mask:3:1
at+set_config=lora:ch_mask:4:1
at+set_config=lora:ch_mask:5:1
at+set_config=lora:ch_mask:6:1
at+set_config=lora:ch_mask:7:1
// Disable channels 8 to 15
at+set_config=lora:ch_mask:8:0
at+set_config=lora:ch_mask:9:0
at+set_config=lora:ch_mask:10:0
at+set_config=lora:ch_mask:11:0
at+set_config=lora:ch_mask:12:0
at+set_config=lora:ch_mask:13:0
at+set_config=lora:ch_mask:14:0
at+set_config=lora:ch_mask:15:0

To appreciate your support, I just recommended the module RAK811 in Nvidia forum - Jetson nano and LoRa - #4 by rajaamp - Jetson Nano - NVIDIA Developer Forums. Hopefully, you will get more order soon.

1 Like