RAK811 setup at+version works all other at commands error

Issue:Just setting up RAK811 breakout board(s). Using either RAK Serial port tool or minicom (debian) nearly all at commands return ERROR-1 or ERROR-2

Setup: Windows 10 PC + RAK Serial Port tool, generic FTDI USB. Same problem on Raspberry pi with a direct UART connection to RAK811 breakout and minicom terminal. RAK 811 Firmware is

Server: NA

Details: Apart from at+version and at+boot which return the expected responses, all other commands I receive ERROR-1 or ERROR-2. This includes basics such as at+get_config=device:status.Any suggestions on what I can try?

The firmware is rather ancient so it may well just understand any of the v3 firmware commands. See:

for details on upgrading.

Welcome to RAK forum @tomcooper :slight_smile:

Can you try at+run?

Also I agree to Nick. That FW is so old. You can also try to update to V3.

Thanks for the suggestions.

  1. at+run gives ERROR-1
  2. I tried upgrading the firmware with RAK Device Firmware Upgrade Tool v1.4 but it keeps timing out:

    I rechecked the connections and tried several times.
  3. With one of the units I downloaded RAK811_v3.0.0.14.H_20200810.bin onto the RAK811 with STM32 CubeProgrammer. That appeared to work OK .

But now the unit is now unresponsive. I’m a bit out of my comfort zone with STM32CubeProgrammer so it’s quite possible I stuffed that up.

I still have one unit left if there is anything else I can try?

The STMCubeProgrammer output was

It’s not showing any errors so you should be able to use the Serial Tool to do the setup.

Thanks Nick, When I go into the serial tool, I get no response. Same via minicom. I’m at a bit of a loss what to try next?

Can you repeat updating the FW using STM32Cube but do not use the .bin file. Use the .hex file. Its the .hex that contains the bootloader and application code.

Thanks Carl (and Nick earlier),

Using the Hex file and STMCubeProgrammer did the trick and the RAK811 responds as expected to at+get_config=device:status etc.

Would have been really stuck without you. Thanks again.


1 Like


What’s in the .bin file then?

Hmmmm, I may know some people with modules we can resurrect.

If you will use the RAK DFU Tool, then .bin file is the one needed since that’s the one with the RAK811 Application FW.

On the .hex, it includes both the bootloader and application FW. Before, v3.x.x.14, the FW for the bootloader is separate, now they are in one .hex file :+1:

1 Like