RAK811 solo No uart comunication with ESP32

Hello community,

I have a weird behaviour i don´t know what to do with it.
Im trying to implement a RAK811 with a esp32 sending AT commands to it.
In my RAK811 development board everyting works even with the Board being powered by the 3.3V of the esp32(note on this part) and only the pins for VCC,GND,antenna and UART1 rx and tx being soldered on (again important part) I even tried to solder directly to the chip while on the dev. board VCC and GND and it worked.
I take out the ship and try to solder the connectors directly and exatly as in the dev. board.
No comunication is seen…
I have tried diferent chips and nothing…only when its in the dev board do i have communication…It must be someting in the RX/TX line that goes wrong.
It should work directly connected to the uart on the chip right?

Hi @bioshock2k , supply lines and UART are the only connections you need to make it work.

Can you share some pics so we can visualize? Thanks.

1 Like

That is true, it’s funny when you are on some days finding a weird behaviour and the time you take about it resolves itself.
It was the grounding on the esp32, moving the ground to another closer to the usb port fixed it! IMG_20210304_224216|375x500
And now I am happily connected.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.