RAK811 unresponsive after bootloader upgrade

Issue: My RAK811 device is no longer responsive when using the RAK serial port tool, RAK frimware upgrader and STM32CubeProgrammer after upgrading the bootloader to v3.0.0.14.H

Setup: I am using a Pi Supply PIS-1136 which utilizes a RAK811(868MHz, Lot number 201916) and an Arduino Nano

Details: I had been using this hardware for a project that requires a LoRa connection but found that none of the at commands were actually working on the Arduino IDE. After switching to the RAK Serial tool to debug I found that the RAK811 was giving and ERROR 1 for every command I was using. AT+Version worked and showed that it was using an old bootloader v2.0.0.?(i cant remember the exact version).

As this hardware didnt have the capability to pull the BOOT0 pin high I soldered a wire to the BOOT0 pin (pin 17) and plugged it in to the 3.3V out of the adruino. The STM32CubeProgrammer seemed to work perfectly, and I made sure to use the .hex file as I had read that somewhere on this forum. The programmer said “upload complete” or something and I then closed the COM port to update the firmware on the RAK firmware tool.

But this is where the problems occured, the device wouldnt open with th firmware upgrade tool giving a message:
“Device Firmware Upgrade time out”.

I then tried to reconnect to the STM32CubeProgrammer to see if I had somehow messed up the board and it would not allow me to connect, giving a message:
“Error: Activating device: KO. Please, verify the boot mode configuration and check the serial port configuration. Reset your device then try again…”

I have tried using different Baud rates, parity etc on both pieces of software as well as trying on a PC rather than a laptop and I even bypassed using the Arduino by using a USB TTL UART cable directly to the RAK811 and have had no luck. All these different attempts give the same error message.

My worry is that I have upgraded the bootloader to an unsupported hardware and now its buggered.

Any help would be appreciated,

Welcome to RAK forum @joshuawallace ,

I hope you uploaded this firmware (the .hex file not bin) using STM32CubeProgrammer.


If not please try to upload it again. It will include the latest bootloader as well as the application code.

Regarding, RAK811 not detected by STM32CubeProgrammer is a different issue. If you were able to connect to it before then likely you are still ok.

Few things to check:

  • Boot0 pin (pulled to VDD. Remove the pull up after detection and uploading.)
  • Supply lines (stable 3.3v)
  • Secured USB to UART converter (no issue USB cable, jumper/header wire, etc.)

The UART Bootloader of STM32 is independent of the RAK Bootloader so you must be able to access it whatever firmware you uploaded previously. Of course unless the UART lines are damaged.

Looking on the picture of the Pi Supply PIS-1136, this is a very very very old version of the RAK811 or it is a fake.
Instead of a LOT number, there should be a DevEUI:

Flashing the latest firmware might have bricked this “maybe” RAK811.