RAK8211 L70GPS and BC95-G not working

Hello,

I am using RAK8211 board, which has quectel L70 and quectel bc95-g.

I am using Segger embedded sudio for programming and have defined all the board pins as per the schematic given in this link:

I have modified the nrfSDK example for serial communication in folder “…/example/peripherals/serial” to establish a communication with either of the two modules.

WHen I send an AT command to BC95-G, I always get an ERROR on the UART. No matter the command, i receive only ERROR.

Whereas, when I try to communicate with the L70 GPS module, I get nothing, not even any junk characters.

I have tried variations of pins and other methods to get them to reply and not to show an abnormal behaviour. Also I have provided a proper power supply and even with batteries. I still have dont receive anything in the buffer in case of L70.

Also the sim slot soldered in the board that i have is 8 PINS whereas the documents and schematic shows 6 pins.

Any pointers or help will be greately appreciated.

Regards,
AMan

Hi,
nRF52832 just has one uart, L70 and bc95G both use it. If you want to use L70R, you need init it to L70 UART pin again. As for bc95G, I am not clear what code do you use? Do you power up bc95g with reset pin and powerkey pin?

This code will help you.
https://github.com/RAKWireless/RUI_itracker_platform_firmware

Hi nero,

nRF has one UART, yes, We have to configure that UART to attach to the pins which we want to use for communication. For now I am configuring and communicating with either BC95-G or L70 GPS at a time. Not communicating or configuring simultaneously.

I powered Up the BC95-G with only GPRS_PWR_ON and RESET pin. There is no Powerkey for BC95-G as per the hardware design guide by quectel. After powering on, When I send “AT\r\n” through UART, I receive “\r\nERROR\r\n” for any command I send. even ATI return an ERROR.

As far as L70 is concerned, I tried all configuration of GPS_PWR_ON/RESET/STANDBY, I dont receive anything after sending “$PQEPE,W,1,1*2A”. I havent been able to reecive anything, not even junk characters from L70 GPS module.

I use segger JLINK for debugging and also provide a 5 volt power supply, whereas your documentation says its 3-18v.

I know I have to init UART AGAIN. I do that and still no response from GPS.

Same code when initialized for BC95-G , I receive ERROR for any command I send.

Regards,
Aman

This link dosent open. Says Page not found.

Regards,
Aman

Can you give me your email?
I can send you a demo code.

I have sent you a message with my email in it

Also I am using the nrf SDK to program peripherals.

your message is sent by our forum marked with [email protected]. I do not find yours.

Please contact me on- [email protected]

Please send me the demo code on the above mentioned email address.

Regards,
Aman