RPi2 with RAK831 - which firmware?

Hi,

looking to update and old Rpi 2 which has a very early install of packet forwarder using Balena.

Went to grab the software here but there is only firmware for 3B+ and 4

Can somebody tell me what is suitable for the RPi2 ?

thanks
Paul

Hei @mutton ,

Try this one. Let me know if it works or you need more help.
https://downloads.rakwireless.com/LoRa/NeoPi-Gateway-RAK7246/Firmware/

Regards
Vladislav

Hello,

how about Raspberry Pi 0? I want to migrate RPi0&RAK831 to v3 from v2, but I can’t find software.

Thank You
Robert

Hei @Roberto69

The one I shared should also work on the RPi0.

Regards
Vladislav

Hello @Hobo, thank you for your response. How can I use this image? If I write it on SD card RPi0 doesn’t come online.

Have you read the guide, do you know that it creates an AP you need to connect to:

@Hobo thank you - I’ve messed with Balena image. Anyway, great manual! It seems works with RPi0, too.
image

But how can I connect it to TTN v3? Nowadays you can’t register gateway in TTN v2 anymore.

Hei,

“sudo gateway-config”

Choose to edit the packet forwarder file. At the end of it is the server address. Replace it with the TTN v3 address of your server, save and you are done.

Regards
Vladislav

Hello @Hobo thank you.

One problem remaining - concentrator doesn’t start:

In Balena I’ve solved this with proper pin for reset, but her I have no idea. There is no other error messages.

Hei,

Ok you can do this:

Clone the repo:

Go to this folder where the start.sh script is. You will find the definition of the reset pin there, change it to the one for the 831:

Once you are done follow the procedure in the repo to install it, the one you want when asked for the model is the RAK2246, which is what the RAK7246 uses.

This should let the concentrator start normally. After you can set the server address as you did before.

Regards
Vladislav

1 Like

@Hobo thank you for your advice. You’ve pointed me into right direction. I have done:

  • update system
  • set DNS entry in /etc/dhcpcd.conf
  • change /opt/ttn-gateway/lora_gateway/reset_lgw.sh line 14 to “IOT_SK_SX1301_RESET_PIN=25”

BTW: I’m using RAK831+RPi0+https://github.com/hallard/RAK831-Zero

After all, there is one error immediately after boot:

login as: xxx
Server refused our key
[email protected]’s password:
Linux rak-gateway 5.10.52+ #1441 Tue Aug 3 18:08:18 BST 2021 armv6l

Which server refused which key?

Regards
Robert

I have no idea this is not our repo, so I haven’t tested it, but it seems to be something local, not related to the LoRaWAN Server.

Regards
Vladislav