RUI3 + Windows 7

is there any way to compile it on Windows 7? I checked on two computers, same problem:

Error loading Python DLL ‘C:\Users\ectar\AppData\Local\Temp_MEI79962\python39.dll’.
LoadLibrary: The specified module could not be found.

I installed some special version of python 3.10 but it didn’t help.

Hello @zolax
I am trying to find someone with Windows 7 to check it. But our office computers are all Windows 10/11 already.

Which ArduinoIDE version are you using? The path looks strange, usually Arduino compilation folders look like C:\Users\Bernd\AppData\Local\Temp\arduino_build_677388

Hi @beegee ,
it was tested on version 1.8.13 and also I update it to 1.8.19. Python updated to 3.10

Are you using Visual Studio or Arduino IDE?
You list Arduino IDE versions, but the screenshot is Visual Studio.

@beegee both, same result.

We are still not able to test on Win 7 unfortunately.
We tested on Win 10/11 andLinux OS with the latest ArduinoIDE and Visual Studio 2019 version 16.11 and Visual Studio Code IDE (VSCodeUserSetup-x64-1.66.2.exe)

For Python, this are the versions our R&D team has installed.

And this are the Python versions on my Win 10 computer

@beegee thanks, for now I will just stick to non RUI3 version, need to update windows at some point anyway :F.

The problem is in the todo-list of our R&D team. If we find a solution I will let you know.

1 Like

@beegee Are you still looking for a test puppy?
I’m still running Win7, my laptop is 10 years old and on to its second keyboard. You sit still for a decade and the rest of the world wanders off somewhere else. WTF?! :upside_down_face:

Welcome to the forum @psupine

You can try it, but I cannot guarantee support if you get stuck.

Installation procedure for Windows 10

I’ve already been through that guide and hit the same limits as the original post, both on Arduino IDE and VS-Code. Arduino and VSCode IDEs both had their idiosyncrasies 18 months ago with the previous RAK firmware, but this time it feels more broken.
I guess I was just checking if it was still on the R+D TODO list. Sounds like not really.

It is still in the list, but with low priority.

Just to close this out, I finally gave up with Win7 and replaced it with Win10.