SCD30 not detected

Hello

I am using a RAK19001 with a RAK11200 I am trying to use the SCD30 CO2 sensor module.

I am able to compile and upload the sketch, however the module errors:

0:43:26.132 → rst:0x1 (POWERON_RESET),boot:0x17 (SPI_FAST_FLASH_BOOT)

00:43:26.132 → configsip: 0, SPIWP:0xee

00:43:26.132 → clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00

00:43:26.132 → mode:DIO, clock div:1

00:43:26.132 → load:0x3fff0030,len:1240

00:43:26.132 → load:0x40078000,len:13012

00:43:26.132 → load:0x40080400,len:3648

00:43:26.132 → entry 0x400805f8

00:43:26.231 → [��mum����2-hal-cpu.c:211] setCpuFrequencyMhz(): PLL: 480 / 2 = 240 Mhz, APB: 80000000 Hz

00:43:27.072 → [ 841][D][esp32-hal-psram.c:84] psramInit(): PSRAM enabled

00:43:27.137 → SCD30 Automatic self-calibration Example.

00:43:27.137 → Air sensor not detected. Please check wiring. Freezing…

I have tried using different IO slots.

The sensor has a slow blinking orange light.

Welcome to the forum @sixteenounces

Do I understand correct that you want to use the RAK12037 CO2 sensor module with the RAK11200 on a RAK19001 board?

Where do you see a slow blinking orange light on the RAK12037? I have this sensor in use and I cannot see any LED on it.

Did you try our example code for the RAK12037 from our WisBlock Examples?

Hey Bernd!

You are correct. When you flip the modules over you can see the orange light between the co2 sensor bonnet and the modules PCB.

I have tried my own code, the basic reading example, and the self calibration example. Each sketch compiled and uploaded no problem, the sensor even seems to have power. However the sensor always fails to initiate / give a reading.

Thanks for your help! Really excited to get started. This isn’t my first ESP but I am pretty green.

hey beegee, i was looking over the examples debug, and it looks like the example sketch when they run, run in DIO mode, however i am flashing is QIO. Does this make a difference or are flash and run time modes independent of each other?

I also came across another forum post about the issue… very similar to my situation, however i am unsure that i could follow the solution with my module, and it seems a bit out of my depth. Was really hoping to “make IoT easy”
https://forum.arduino.cc/t/scd30-solved/539505/4

Did you try the example I pointed you to? RAK12037_BasicReadings_SCD30

It works just fine for me.

@beegee I did infact try all the example code from github as well as the examples in arduino IDE for my board. I also tried to use some of the examples that came with the SparkFun library.

Below you can see me compile and upload the same sketch as you and the sensor fails to be found/recognized… However. Again. I do have a slow orange breathing light on the SCD30

I have tried everything with this sensor. I have multiple hours into it. Could there be an issue with my bootloader, could my base board or core module be damaged?

Like I said previously, I am pretty new, however I have built a few ESP solutions, and never had this much issue.


As a note I also have a SDI-12 module that fails to retrieve data from my SDI-12 sensors. Unsure if they are even being powered. I have tried with external and internal 12v supply. I have multiple different SDI-12 sensor manufacturers, that have all been verified working on another data logger. I have tried with the 1.0.0 library and the examples from github, and I have tried with the 1.0.1 library and the examples that were included with that library. The GitHub examples for SDI-12 fail to compile using the 1.0.1 library. You can only compile the GitHub samples with the 1.0.0 library.

I have tried both modules individually just to make sure there were no pin issues…

Just really feeling defeated here. And hoping there is some small piece i am missing here.

I am not sure what’s happening here.
Do you have another WisBlock Base Board for testing? I used the same combination of RAK19011, RAK19012 and RAK11200 and it works.

The RAK19011 has most signals on the pin headers, can you measure the voltages of 3V3, VDD and VBAT?

Does using the other IO slot change something?

For the SDI-12 library, can you send me the compilation error you are getting. I guess the examples have to be updated.