Send AT commands cause the incoming messages to arrive continually (RAK5205)

When I connect the 5205 to my laptop and send AT commands using RAK tool/TeraTerm everything works fine. When trying to connect it to my LattePanda V1.0 (win10) ( and send AT command (from the RAK serial com tool or TeraTerm) the incoming messages /logs arriving without stopping for long time.


The restart may be caused by insufficient power supply.

Thanks Nicholas,
The device connected directly to the Panda… How can I check that is the problem?

You can check the following documents to find the corresponding TX and RX pin port, through the serial port and panda… Connect, power supply can be powered by batteries, panda… Is used to check whether the log printed by serial port is normal.

Thanks @Nicholas.

  1. Change J25 jumper
  2. Connect UART1_TX & UART1_RX pins from J22 to the pc with usb to serial
  3. Connect 3.7V to the Li-ion battery connector
    It seems that the device doesn’t have the same restart issue as before but the output on the terminal is not correct (see in the screenshot). Do I have to change the terminal settings?


Change J25 jumper?How do you operate this step, can you take photos for me? There is no need to jumper J25.

Rx connect to Rx1

Are you currently connected to LattePanda V1.0 (win10)? Maybe you can try it on your laptop.

Trying now with my laptop and DC Power Supply (3.7V) and see the same

Can I send AT command through serial port tool?

No. I can’t send AT command. The picture took after pressing the reset button
Also tested with TeraTerm

Note that the board’s TX needs to be connected to the serial port tool’s RX, and the board’s RX needs to be connected to the serial port’s TX.

Yes exactly - TX-RX & RX-TX & Gnd-Gnd
The firmware I’m using -

  1. You can send AT command to lower baud rate by connecting USB: AT+SET _ CONFIG = DEVICE: UART: 1: 9600
  2. Connect uart serial port tool via laptop and change baud rate to 9600.
  3. Is it normal to continue sending at command.

I change the baud rate to 9600 (AT+SET_CONFIG=DEVICE:UART:1:9600)
I’m still can’t run the last setup (DC supplier to the battery connector and UART1_tx/Uart1_rx to the Laptop via USB to Serial) BUT
The original setup - connect the 5205 to the LattePanda via the USB (power from USB) works! the change to BR 9600 fix the multi-restart issue.
Thanks @Nicholas!

It seems that due to the power supply problem, the demand for power supply is also reduced after the baud rate is lowered.