Sending odd number of bytes

Why I’m not able to send odd number of bytes with an AT command in p2p mode? Even number works fine.

For example:
“at+send=lorap2p:12” works perfectly
“at+send=lorap2p:123” doesn’t work, ERROR: 2 (“Invalid parameter in the AT command.”)


Because it’s not a number, it’s a hex string, so 12 is sending the number 18 in decimal.

To complete @nmcc answer, you need to think Hex and not decimal so to send 123 decimal number you’ll need to write 0x7B! You can Use this site to help with conversions:

You would write your example as follow: