Serial connection issue

Hi everyone, I’m having trouble sending Arduino sketch to a wisblock 4631, getting this message…

Tried different usb cables, restarting arduino, pressing the reset button etc.
Tried also to update the bootloader to 0.4.1, but getting this error…

Any ideas?

Did you try to put the module into UF2 mode by double pushing the reset button?

Are there any other applications active? I have problems when I have my 3D printer slicer Cura running. Out of some reasons it opens and occupies all COM ports it can find (to be able to connect to a 3D printer).

Yep, that works fine…it’s weird, as I’ve used this computer for all my Wisblock/arduino stuff. I have had a few connection issues before, but usually a restart or hitting the reset on the wisblock fixes it. This is very consistant.
I’m not aware of any other applications running that would cause this…would there be any way to check?


I think it may be board specific, as I tried another one and got it to work with both blinky sketch and mine (weather station). It does do funky things like changes usb, but that always seems to happen.
I do have sda/scl connected, but is there anything I can to to check a specific board other than throwing it away? Is there any way to reset/format or similar?

Hi @Andy
The bootloader is outdated and had problems with the USB connection. Please update it to the latest version following our guide on Github

For the change of USB port during uploading a firmware, that is normal. It is caused by the bootloader.

Thanks for the update @beegee, but won’t I come across the same issue as my attempt to update in the second screenshot of my first post? It seems to have an issue connecting to the board.
I do happen to have a RAKDAP1 with me, might that be a more direct way to get it working? Looks like it involves soldering to the RAK4631, which isn’t ideal.

Set up and getting this error on execution…

And this is the result of another attempt at usb upgrade…

Hi Andy

  1. Flashing with RAKDAP1 doesn’t require soldering, what I am usually doing is just to put in a pin header and apply pressure to ensure the contact is good:

  2. Error “incalid record” in bootloader hex file. Please download the file again, I am sure the file is ok, I am using it all the time to update RAK4631’s

  3. “Failed to upgrade target”. I am not sure what is causing this error. Did you try to put the RAK4631 into UF2 mode first (double reset push), then run adafruit-nrfutil.exe with the new COM port that is showing up in UF2 mode?

Got it, thanks for taking the time to help with this @beegee, I hadn’t done the UF2 mode first. Once I did this, it failed the first time, then worked. I thought the UF2 mode was simply to look at the text file to check version of bootloader. The github link you gave earlier doesn’t indicate this either, might be handy to add?
Another quick question, there was no download option for the .hex file on Github, so I went up a level and saved the target…possibly why it failed? The only other option would be to copy the contents, paste into notepad++, and save with the same name?

Seems we need to improve the documentation.
The download links are in the Releases of the WisBlock repo:

Perfect, thanks @beegee