Setup issues with rak7248

Hello Forum members,

I have already opened ticket for these issues but so far i have not received any answer on those. That’s why i give it a try here as well…

I have ordered 3x Hotspot v2 in december which just arrived. I was really happy until i tried to do the onboarding. Only 1 got sucesfully onborded the other 2 are generating issues:

the 1st hotspot v2 (RAK7248) when i try to register it tells me someone else is owning it. I have no idea how is that possible at all.

The 2nd hotspot v2 is generating a slightly different issue. When i am going through on the registration process, the BT come up, i am able to connect but at the very next step, it tells me “No manufacturer found for this hotspot”. So no next step to configure the antenna and the location of the device.

it is really annoying when finally I got these devices and i can not get them up and running.

So far i have tried to do the registration with the black helium wallet app. Tried the blue helium app as well. NOw i have tried to install the firmware on a new SD card and boot up from it (and waiting at least 30 minutes as it is in docs) but so far i have no luck.

Anyone has any other suggestion? I know in China there is a new year celebration and support is a bit slow… but regardless i want to have some progress on these faulty devices…


I have same case of yours first case, and emailed the sales team since Thrusday and no respond from their side yet.

It looks manufacture mistake, they might used second-hand lora modules that was returned by another customers during warranty period for the new batch.

I am woried this can’t be solved even if they own that wallet and can transfer the NFT to us because in my case the hotspot was onboarded on China and the frequency used in china is different than EU868.

Hope this solve soon

Thanks for the info. This kind of situation would explain it… Although it is really sad, a company who is a key player in this industry was not thinking about the consequences of reusing radio modules withouthre-configuring with new serial number.

I hope both of my issues will be sorted shortly!

Just an update… using a re-installed SD card did not solve either of these problems. Also what i have learn from this situation is, the type of the SD card is important. Device was not able to get to the part where it is able to pair via BT to the phone when i used no name SD cards. It was able to boot sucesfully with sandisk SD card but still the registration to the Helium netork is failing.

Same situation here. No customer service.

Hotspotty said ‘Gateway onboarding error: this hotspot has already been created’.

Helium wallet said ‘This hotspot is already onboarded’.

So, in essence; are they really selling 2nd hand devices? It says on their website that there will be no refunds. So is RAK a big fat scam operation, and if it is, how to stop them?

I do not think that is true regarding to refund. Their website says you can refund it in 30 days but they approval is needed. Also it comes with 1 year warranty. They are telling to use the form from their website. Used that and i have 3 tickets open at their zendesk. No response at all. It is really a shady business model! They are pushing the sales but no support! I am fully disappointed and could not recommend to anyone who is looking to get into helium

The sales page says that ‘…discounted (sale) items are non-returnable and not-refundable.’ (I got mine 10% off.) It also says ‘This does not restrict your rights in the event the product is defective.’. I have two open tickets but I’m not too confident…

My other two RAK hotspots has disappeared from the explorer hex. No rewards for two days, either. By coincidence (?) the same day when I plugged in the one with issues.