[Solved] RAK7258 Firmwares 64 and 65 need a change in configuration for TTN

Issue: I am running a RAK7258 with success since October 2019 now, with Things Network. When I tried to upgrade its firmware to version 64 or 65 (r208 or r209) the device seemed to be working but stopped forwarding the data packets to the TTN routers. Firmware 63 works fine. I flashed the device several time so the problem is reporductible. Any help is appreciated

Setup: Indoor,

LoRa® Server: Things Network Europe?

Details: Firmware Version 1.1.0063_Release r205 (last one working!)

Hi @ande,
The r205 release is the last version that comes with a default packet forwarder set to Semtech UDP with a server address TTN. After this version (at r209 for example) the default mode of the LoRaWan Network Settings is “Network server”.
Have you set it to TTN?
This is how your settings should look like:

That did the trick, many thanks!

I don’t want to be overlc critic, apparently I had hoped for the updater to change it automatically :slight_smile: - all the better that others can read this now :slight_smile:

Also the .zip filed did unpack, but then only the .bin file and said that it could not unpack on a Mac. Maybe it failed to unpack instructions?

Have a nice day -

Hi @ande,
You don’t need to unpack the .bin file. When you unpack the .zip file, you will see the bin file, which you need to flash on the gateway.

I know but I was not sure if the .zip contains other files:

Here is the message I get…“could not be unpacked. The format is not supported”.


No the zip file does not contain other files that the .bin file with the firmware.

Ah OK then the Mac OS just didn’t know what to do with the .bin

Again, many thanks!

When comparing, so far I think your gateway is one of the most reasonable and affordable ones!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.