"Start sending" message stuck when firmware upgrading

Issue: “Start sending” stuck when firmware upgrading
Setup: RAK811 915Mhz- OTAA, USB to Laptop
Server: ChirpStack
Details: I deleted the memory and installed the bootloader (RAK811_BOOT_V3.0.2.bin) onto the RAK811. Next I tried to install the latest firmware for my band (RAK811_v3.0.0.14.H_20200810.bin). I purchased it recently and originally had the beta version on it, which i can’t find anywhere. Within the RAK LoRaButton Upgrade Tool I am recieving a “Start sending…” message with no movement of the progress bar. The Led2(Tx) keeps flashing as well. The “Upgrade Success!” message never displays and I an not able to write or read from the RAK Serial Port Tool.

I enter the following in it:

AT cmd error.

Here is a screenshot after I have installed the bootloader and try to install the firmware:

The message never advances and the firmware never installs

Dear Johnnystran,

where did you get this latest firmware?

This firmware not applicable to the bootloader (RAK811_BOOT_V3.0.2.bin) version.

I will send your the latest version include bootloader and firmware if you need.

Please private chat me!

Best regards!

I got the firmware from: https://downloads.rakwireless.com/LoRa/RAK811/Firmware/

Please send me the latest version of both bootloader and firmware, thank you!


I also cannot flash RAK811_v3.0.0.14.H_20200810.bin in older RAK lora wireless. I still not update
RUI_RAK811_V3.0.0.12.H.T_Release.bin is used and can update software but RAK811_v3.0.0.14.H_20200810.bin cannot. need to update bootloader?

Best Regards

Dear Ye,

Why did you upgrade the firmware, the original version was that one?


I want to use latest firmware and there is auto retry for lora join in version RUI_RAK811_V3.0.0.12.H.T_Release.bin? i want to disable auto join in lora wan. latest firmware disable it already?

Best Regards

Dear Ye,

Please send me the e-mail!

[email protected]

Best regards!

I am having the exact issue when upgrading my bootloader.
Exact scenario as described above.
Could you send me the combination of bootloader/firmware i need?

Hi @bioshock2k please find the latest firmware here. The hex file can be used with the STM32Cube programmer to flash both the firmware and the bootloader. After you are with the latest one you can use only the RAK DFU Tool for future updates and flashing the RUI compiled firmware.


Thanks but using bootloader 3.0.2 the only FW that worked was It uploaded fine, the latest it didn´t.

The file that I shared is with included bootloader 3.0.5 - the latest one, only firmware 3.x.x.14 and up can be used. You can flash the whole HEX file(bootloader+firmware) with the STM32 Cube programmer.


The bootloader+FW seems like a more effiecient way to go!

1 Like

Hi! I downloaded the RAK811_v3.0.0.14.H_20200810.bin file from your link. I flashed it using STM32Cube. However, module does not respond to either DFUTool or RAK_Serial_Port_Tool. Do I understand correctly that this file contains both the bootloader and the firmware?

Hi @BoolAB Can you try the hex file with the STM32Cube programmer? Also what returns the at+boot command?

It’s a miracle! Yesterday I killed the whole evening trying to revive the device. Today, after the flashed .HEX started working right away! Many thanks!

@BoolAB Glad, you made it! Probably we need to update the docs with this part :slight_smile: