Strange behavior of the module 4270

I’m getting incorrect data
I am doing a long-term stress test of the RAK4270 module. The kit is like this:
The transmitter. RAK4270 module, antenna, powered by 3.3-3.4V LiPo battery. The module contains the LoRa_P2P_Send firmware from the examples.
The receiver. RAK4270 module, antenna, powered by a laboratory source, RS232 interface converter. The module contains the LoRa_P2P_Recv firmware from the examples. The module is connected to a PC to display the received data.

At first I get the data as intended
After several hours of continuous operation, the receiver shows several errors, then the received data differs from the correct ones.

7:22:30.455, at+recv=-12,12,32:B300000000000000000000000000000000000000000000000000000000000000
7:22:40.580, at+recv=-12,12,32:B400000000000000000000000000000000000000000000000000000000000000
7:22:50.775, at+recv=-12,12,32:B500000000000000000000000000000000000000000000000000000000000000
7:23:00.871, at+recv=-12,12,32:B600000000000000000000000000000000000000000000000000000000000000
7:24:01.363, ERROR: 95
7:25:02.308, ERROR: 95
7:26:03.066, ERROR: 95
7:26:43.609, ERROR: 95
7:26:53.706, ERROR: 95
7:28:15.357, at+recv=-74,-16,229:31C3681245229332CBD5EC0FA0A5E2054734F576146EA293A98B81387419B45C98C935275DD0F8CB97DF134A3753A262643C7CE2619B61C1298697B69A8D78A6C2ECE13A8A82B5357E62A9EC20B4879B424931B86DCB3624319911281380A9411310D35708D0D04059EAB1CD1B32F8A84D5BAC18A68B9BEC4D4E98364537D2BCC5ED8A7DE56583AC72AED46F9D007AB39D45F3CCD8F021FAF2FE02F7B96E6D5F1C6F2127C4B52B10488741B7B208CC9C5B7ADB19FCE0849E8DBED009597B980FD8A4AD81050BAE159D222CCCDCCB9D287FA2DEF4CC68ABA953967FC4AD68F50B472C316629
7:28:34.985, at+recv=-66,-10,229:31C3681245229332CBD5EC0FA0A5E2054734F576146EA293A98B81387419B45C98C935275DD0F8CB97DF134A3753A262643C7CE2619B61C1298697B69A8D78A6C2ECE13A8A82B5357E62A9EC20B4879B424931B86DCB3624319911281380A9411310D35708D0D04059EAB1CD1B32F8A84D5BAC18A68B9BEC4D4E98364537D2BCC5ED8A7DE56583AC72AED46F9D007AB39D45F3CCD8F021FAF2FE02F7B96E6D5F1C6F2127C4B52B10488741B7B208CC9C5B7ADB19FCE0849E8DBED009597B980FD8A4AD81050BAE159D222CCCDCCB9D287FA2DEF4CC68ABA953967FC4AD68F50B472C316629
7:28:45.172, ERROR: 95
7:29:05.474, at+recv=-66,-10,229:31C3681245229332CBD5EC0FA0A5E2054734F576146EA293A98B81387419B45C98C935275DD0F8CB97DF134A3753A262643C7CE2619B61C1298697B69A8D78A6C2ECE13A8A82B5357E62A9EC20B4879B424931B86DCB3624319911281380A9411310D35708D0D04059EAB1CD1B32F8A84D5BAC18A68B9BEC4D4E98364537D2BCC5ED8A7DE56583AC72AED46F9D007AB39D45F3CCD8F021FAF2FE02F7B96E6D5F1C6F2127C4B52B10488741B7B208CC9C5B7ADB19FCE0849E8DBED009597B980FD8A4AD81050BAE159D222CCCDCCB9D287FA2DEF4CC68ABA953967FC4AD68F50B472C316629
7:30:36.516, ERROR: 95

The problem is solved when I reset the transmitter module. For the next few hours, the data goes fine. Then the failure repeats. So it’s the transmitter sending the wrong data.
Why is he doing this?

Welcome back to RAK forum @BoolAB ,

Indeed it is strange. Even the ERROR on the receiver side is strange since it is RX1 window error while you are in LoRa P2P mode.

Just to get more info, what happened during the long-term stress test? Are both RX and TX modules subjected to this test? Could it be possible that it damage the module? When uploading the firmware did you erase the memory first? What are the parameters used on LoRa P2P? Like frequency, datarate, etc.?

During a long test, both modules lie on the table without any external influence. They are located at a distance of less than one meter from each other.
The subject of the test is the transmitter: I need to determine how long it will be able to work on one battery without additional charge. Therefore, the receiver is powered by a laboratory source. The restart of the transmitter leads to the restoration of the correct transmission, the receiver continues to work at this time.
In the LoRa_P2P settings, everything is by default as in the example.

OK work_mode: LoRa P2P

Before writing the loader via ST-Link, the controller’s memory was cleared. I filled in RAK4270_v3.3.0.17. I compiled LoRa_P2P applications in RUI Online Compiler about a month ago. After writing the application to the module, it began to respond to the at+version command with “V3.3.0.19”

Hello everybody!
The question is solved. It turned out to be an interesting story.
Yesterday, the battery that powered the transmitter module was completely discharged. I turned it off. The receiver module remained switched on. I continued to sometimes accept incomprehensible packages and errors.
I think that somewhere not very far away there is some other device operating on the LoRa frequency. The signal from it is very small, so it only sometimes conflicted with the signal from my transmitter module.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.