Timestamp not accurate


We have two 7249 gateways, they are currently sitting next to each other as we are in the process of testing them. The uplink we see on TTES (TTN enterprise) from our test device shows the following:

“gateway_ids”: {
“gateway_id”: “7249-0456c0”,
“eui”: “AC1F09FFFE004F2D”
"timestamp": 846965756,
“rssi”: -52,
“channel_rssi”: -52,
“snr”: 8.5,
“gateway_ids”: {
“gateway_id”: “7249-0147ae”,
“eui”: “AC1F09FFFE0147AE”
"timestamp": 2685179924,
“rssi”: -44,
“channel_rssi”: -44,
“snr”: 9.8,

My question is regarding the timestamps.

2685179924 = Tuesday, 2 February 2055 11:18:44
846965756 = : Saturday, 2 November 1996 20:15:56

Both devices have GPS working and NTP enabled. The system time is also showing correctly both via the terminal (SSH) and the webgui

Is this expected and if so why? If it isn’t expected, what can I do to get an accurate timestamp here?

If anyone can help I would be very grateful.

Many thanks

These are not “calendar” timestamps, rather they are independent free running microsecond counters of 32 bits which periodically wrap around through zero.

They are only useful in the context of a gateway itself, over short time periods - typically to transmit a downlink reply starting exactly 1 second after the end of an uplink.

What you are showing is not the output of the gateway, but a summary produced by your server. It would appear that even if the gateways are including a calendar time in their uplink reports, you server is not passing that on. The first thing you should do is research if that server is supposed to. You could then check the raw uplink messages from gateway to server to see if those include a calendar time.