Twilio / T-Mobile SIM with RAK7258 gives QMUXError = 0xe

We are using a Twilio SIM with the RAK7258. The SIM uses T-Mobile carrier service here in the USA. When we enable LTE, it connects briefly and then disconnects, repeatedly. In the system log it shows:

Wed Dec 18 20:01:04 2019 quectel-CM[16868]: requestRegistrationState2 MCC: 310, MNC: 260, PS: Attached, DataCap: LTE
Wed Dec 18 20:01:04 2019 quectel-CM[16868]: requestSetupDataCall QMUXResult = 0x1, QMUXError = 0xe
Wed Dec 18 20:01:09 2019 quectel-CM[16868]: requestRegistrationState2 MCC: 310, MNC: 260, PS: Attached, DataCap: LTE
Wed Dec 18 20:01:09 2019 quectel-CM[16868]: requestSetupDataCall QMUXResult = 0x1, QMUXError = 0xe

The SIM works fine in other equipment. Also a different SIM (from our local AT&T mobile carrier) works fine in the RAK7258. Any ideas on why the Twilio/T-Mobile SIM is not working, or what we could try to fix it?

We have also now tried an official T-Mobile SIM, but get the same errors. It appears that the RAK7258 does not work on the T-Mobile network at all.

Can you confirm that APN name and PIN are set correctly?
If No PIN and already tried with APN name, please try leaving APN field blank.

Yes, the APN is set correctly and there is no PIN for this SIM (confirmed both). I tried leaving the APN field blank but the error message does not change. Same problem.

I am also in contact with Twilio to see if they can provide any information on the error message. Their support person asked if you could identify which of the four models of Quectel EG95 listed here is used in the RAK7258:


Asking this question again because we have not received a response and are running low on time in our evaluation of your equipment for use in our network.

Can you please confirm which specific model of Quectel EG95 is used in the RAK7258?

Hi @faludi. Sorry for late replay :frowning: . For USA, EG95-NA is used.
Please feel free to contact me at [email protected] for future assistans on this.

Best regards.

Any updates on this? I’m running into the same issue with a RAK 7240 and a genuine T-Mobile SIM. No PIN on the card & with or without the APN ( added, it just won’t talk to the T-Mobile network.

No updates. RAK didn’t follow up and Twillio wasn’t able to get T-Mobile to care about it so I’d just use AT&T or a different gateway.

Very interesting. I seem to have a problem with my EG95-NA modem: With a known good SIM card, AT&T refuses to connect to the network. More precisely, I see in the statistics that several packets were sent, but there is no real connection.
I think this is a firmware problem, however I found a swollen electrolytic capacitor (C39, 220uF x 25V) on the board.
But for now, I’m experimenting, and I’ll be able to say something definite after I replace it.

Also, I found an interesting link:

Did anyone succeed in connecting a T-Mobile sim or hologram sim?

nothing seems to work

I have the same problem with US Mobile, which uses T-Mobile for the GSM 4G LTE sim card. I have the same error code.

While others have reported problems with T-Mobile, I have used Hologram sim on the T-Mobile plan and that does work. I’m not sure if it is Hologram or T-Mobile making it work. My US Mobile sim does TX to the network to register. The US Mobile dashboard shows it activated.

Just some added info - I did take the US Mobile sim card and put in my phone and it worked. So, I know it’s not the US Mobile sim(physically) and the modem does work with T-Mobile based on the Hologram sim working on T-Mobile…

Any thoughts on why this is so?

Dosnt look like anyone will answer im stock with this for a while with no help

I was told by the US Mobile team they do not support my 7240 with Quecel chip.

Further research is telling me there is something in the setup of the service that allows data roaming. Most of the US carriers do not support that. As I mentioned before, I have tested the Hologram sims and another company that was referred to me was Soracom. They are very similar in features and cost - which is a deal killer…hope you had better luck!

i use hologram too and t mobile in a sim stick and connect in to a gateway

1 Like

sorry - sim stick? could you elaborate?