Unable to Access UART3 on WisNode-Lora V1.2

WisNode-1.2 with following queryies. Firmware Version:

  1. UART communication on UART3 on WisNode V1.2, Not able to receive RX data?
    info: we are able to send data on UART3 TX pin and successfully received on serial port.
  2. On website https://downloads.rakwireless.com/en/LoRa/WisNode/Hardware-Specification/

WisNode_LoRa_SCH_V1.2.pdf : here the schematic shows RAK811 New Pin and RAK811 Old Pin how do we identify our RAK811 has old or new pins. (Atteched image of WisNode V1.2)

  1. Last Query on AT command given as below, After setting uart-3 mode to 1, each at command will responded with “unvarnished transmit mode” as shown below image

Current AT uart work mode:unvarnished transmit mode

Thanks And Regards

Hi @urvil,
This version firmware has not support unvarnished transmit mode with UART3.
You can exit this mode to normal mode by send “+++”(no"\r\n"and"") to UART1.
The unvarnished transmit mode for UART1 :received any data but “+++” will be send to LoRaWAN if LoRaWAN had joined.

Hi @leopold,
Thanks For Quick Response.
but can you describe more on command “send “+++”(no”\r\n"and"") to UART1." with example.

Also can you check question 1 and 2 as well, or point it to respective person.

  1. How do we send data to RAK811 using UART3 RX.
  2. How to identify Old Pin and New Pin, as 811 stamp only has lot number on it.
  3. How we can use UART 2 and 3 ?


Hi @urvil,
answer1:UART3 has not support RX by AT cmd.It use for RUI interface.
answer2:New RAK811 module Pin is compatible Old module .It distinguish high frequence and low frequence.

answer3:The current firmware has not full usage with UART 2 and 3 by AT command,you can use operate by our RUI platform.


Thanks, will try RUI Platform.

Hi @leopold,
I tried first example from location https://github.com/RAKWireless/Products_practice_based_on_RUI/blob/master/based%20on%20RAK811/RAK811_DEMO_application/app.c

  1. It is fail to compile with following errors.
    ERRORS: In function ‘LoRaWANJoined_callback’:
    error: ‘RUI_DEVICE_STATUS_T {aka struct RUI_DEVICE_STATUS}’ has no member named ‘lora_dr’

Multiple errors for same Struct, i have check RUI Api document at location below, but could not find any such structure. “https://downloads.rakwireless.com/en/RUI/RUI_API_Reference_V1.0.pdf

  1. Also in RakOnline compiler guide document shows some python script to compile and i havent found that in my login. so i followed from help and used below command to compile
    rak_rui_build “P=3” "D=H"


hi,you could try rak7204 demo,some rui has been modify today but not adapt rak811 yet.I’m sorry for it.We’ll improve it as soon as possible.

Hi @leopold,

Today after compilation message got, “Your compilation request is in second place, please continue to wait.”. After waiting for 1 hr still file is not compiled.

Please add some information about compiler status for all devices along with rak_rui_help message. This information will be very helpful to developer and also less forum queries… :slight_smile:

Thanks and Regards

@ZhuQI, @leopold,

Any update on RUI RAK811 update, got below answer from Leopold before 6 days. We need serial communication with the GSM module for product, do need full ASAP.

“hi,you could try rak7204 demo,some rui has been modify today but not adapt rak811 yet.I’m sorry for it.We’ll improve it as soon as possible.”

Yet, unable to compile any of the two commands shown below, with the same error given previously.

Let me know if you guys need any help in development ([email protected])


I’m sorry to reply so late.Github has update about RAK811 demo:https://github.com/RAKWireless/Products_practice_based_on_RUI/tree/master/based%20on%20RAK811/RAK811_DEMO_application.
You can download and try again.

Hi @leopold,

Thanks, New sample code compiled successfully but after uploading on RAK811, got not a single debug as mentioned in the example.

Secondly, after first successfull compile, No new compilation completes after message “Your compilation request is in first place, please continue to wait.”


I am very sorry to have this bug.
I will fix it as soon as possible.
I have removed you from the waiting queue.

Hi @urvil,
You can refer to RAK7204 demo,it add a sensor bme680 based on RAK811 demo :https://github.com/RAKWireless/Products_practice_based_on_RUI/tree/master/based%20on%20RAK811/RAK7204

Hello @ZhuQI,
Only once compile allowed, after that again i got stuck in waiting list. Is there any command to get out of waiting queue?


I will add this feature as soon as possible.

Hi @ZhuQI,

Thanks, But for now is there any alternative, not compiling after you allowed.

What is the username you use to log in to the server?

username: rak10014
current compile info: “Your compilation request is in 4th place, please continue to wait.”

I am currently viewing the server log online, can you run it once?

Done, ecxecute compile command