Unable to add BSP via Arduino Board Manager

I am following the RAK3172 Module Quick Start Guide and am having trouble adding the board via the Board Manager. After adding the URL and restarting the IDE, no boards show up with a search for “RAK”. I am using Arduino IDE 2.2.1 which was downloaded from the Arduino site and not the Windows Store. Please see this screen capture of the process.

It could be a problem with the installation.
Can you try to check on the output window of ArduinoIDE if there is something showing after you added the URL?
If there is a problem to access the URL or to download the BSP, there should be an error message.

(Above was an successful installation)

You can see this window by clicking on Toggle Bottom Panel on the bottom right side of ArduinoIDE:

When I enter this URL and click OK, nothing is printed in the Output and no boards show up.

I just tried this link for Wisblock and it does work. It seems like there is something wrong with the first link.

This is exactly the URL I am using

You can test the URL by pasting it in your browser and you should see something like this:

If that works, there is one option you can try (I still think ArduinoIDE V2.x.x is buggy)

(1) Install the old ArduinoIDE V1.8.19
(2) Try to install the BSP from the old ArduinoIDE

The two versions share the same folder for the BSP’s and libraries, so when you install in V1.x, it is visible in V2.x of ArduinoIDE

I run a test, cleaned up the Arduino installation folder (removed cache, staging folder, removed the RUI3 JSON file and the complete installation of RUI3 BSP) and I am now having the same issue.
In ArduinoIDE V2.2.1 I can’t see the RUI3 boards, in V1.8.19 I see them.

I have no idea why V2.2.1 doesn’t update the boards list. Only option to install is through the old V1.8.19

No RUI3 boards in V2.2.1:

All RUI3 boards in V1.8.19:

Adding the boards via 1.8.19 worked for me as well! Once downloaded they are accessible from 2.2.1.
Thanks for the support on this!

It’s getting weirder:
After 2 times restarting V2.2.1, starting one time V1.8.19, the boards suddenly showed up :thinking:
Maybe some caching is happening there :thinking:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.