Unable to launch bootloader on Linux or Mac

Hello,

I have these connected and unable to launch the bootloader on my Linux laptop or on MacBook pro:

  • WisBlock Base Board 2nd Gen | RAK19007
  • Raspberry Pi RP2040 Core Module for LoRaWAN | RAK11310
  • QWIIC Module | RAK13009
  • Relay Module 250VAC 5A/10A Omron G5LE-14 DC3 | RAK13007

I tried the steps to upload firmware in this page: RAK11310 Quick Start Guide | RAKwireless Documentation Center

  • Click the reset button of the WisBlock Base Board twice to enable the USB Bootloader mode of the RAK11300 module.
  • Hold the BootSel button in the RAK11300 module, reset the module (press the reset button of WisBlock Base Board for at least 2 seconds) then wait for the USB Mass Storage RPI-RP2 to appear before releasing the BootSel button.

Both the methods failed. Base board has red light flickering. It isn’t solid red or even blinking. I have tried this with other few boards and same result. Linux USB ports do not detect anything when the board is connected while trying all steps.

Is there a video which shows how this needs to be done or anyone else who has this configuration with Macbook pro faced this same issues?

PS: I have tried with 5 boards with 5 RAK113100 CPU’s and none worked.


Thanks,
AC

Welcome to RAK forum @dexterac ,

I am using macOS Big Sur 11.6.7 and it is working fine.

I tested two RAK11310 core boards on different baseboards - RAK19007, RAK19003 and RAK5005-O. All work fine.

I have few question that might help us troubleshoot.

  1. Did you install the Arduino BSP and the latest version?

  2. Can you confirm that nothing detected by the Arduino?

  3. When you hold BootSel button and click reset button of the base board, is there an RPI-RP2 in the drives of macOS?

image

  1. Did you use different USB cable when you did the test?
  2. Can you try to plug a battery on the board so it will get a more stable power than the USB port?
  3. When you said macOS and Linux, have you make it worked in Windows?

Hi @carlrowan ,

I’m using PlatformIO and have patched with RP2040 so compile works. I had ordered 5 WisBase boards so I started swapping to try variety of combinations.

2 of the 5 base boards are working well. 3 are not.

When I connect the working boards I see this output with dmesg:

dmesg
[12639.481621] usb 5-2: new full-speed USB device number 74 using xhci_hcd
[12639.655206] usb 5-2: New USB device found, idVendor=2e8a, idProduct=00c0, bcdDevice= 1.01
[12639.655218] usb 5-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[12639.655222] usb 5-2: Product: WisBlock RAK11300 Board
[12639.655225] usb 5-2: Manufacturer: Arduino
[12639.655228] usb 5-2: SerialNumber: 518460E622307653
[12639.683341] cdc_acm 5-2:1.0: ttyACM0: USB ACM device

With the other 3 that are not working I do not get any output on dmesg.
It appears that 3 of the 5 Base boards are DOA.

Hi @carlrowan

Unfortunately I do not have a Windows machine.

I tried 3 different cables and result was same.

After trying a few combinations I see 2 of the 5 boards are working fine. Other 3 do not work.
I tried with a battery connected and result was same.


Thanks,
AC

Thanks for sharing more info. Hmm. Have you tried uploading the firmware on the 3 non-working boards as mentioned in this guide - RAK11300 Module Quick Start Guide | RAKwireless Documentation Center

I have tried. All these 3 boards do not get detected in dmesg. I tried changing usb cable, attach a battery and even use a CPU which was updated using the other 2 working boards. These 3 boards still do not work.

Any suggestion on how to fix a RAK19007 base board?

Do you think the issue is with the RAK19007? I mean if you put the RAK11310 on a working base board, it works?

Yes. You are correct. Issue is with those 3 boards.

When I put the CPU in 2 boards it works. The 3 faulty RAK19007 boards it doesn’t work.

I borrowed a Windows laptop to try and still facing same issue.

Seems the baseboard then. I sent you a message for possible replacement. It is hard to know the actual cause of the issue unless we see the actual board :pensive:

Thanks Carl. I have created a ticket for replacement.