Unable to program RAK3272-SiP with FTDI

My team and I are working on an implementing the rak3272 in a LEO sat. Unfortunately, I am unable to program the chip. I tried programming it with the FTDI FT232 Chip with the UART.

The chip is recognized by the STM32Cube programmer and STLINKV2. When trying to upload via the Arduino IDE, the code uploads (with the FTDI). However, it does not execute (the code). All AT commands work. AT, AT+VER=? also work.


The code fails to execute even after manually resetting the chip with the RST and GND pins connected by a wire.

Another point of concern is that the AppEUI. DevEUI and APPKey are all strings of zeros.

Also 8/10 times, the code fails to upload with the “Device not in bootmode” error. The chip is not configured for LORA P2P or as a device that can connect to a network yet.

What could be the probable issue behind this?

Code tested with:

void setup()
    Serial.println("RAKwireless RAK3272-SiP Example");

void loop()
    /* Destroy this busy loop and use timer to do what you want instead,
     * so that the system thread can auto enter low power mode by api.system.lpm.set(1); */

Arduino IDE Version: 1.8.19

When you see the “Device not in bootmode” error, open the Serial console and type AT+BOOT, then enter. This will put the device in, well :grinning:, boot mode, and upload can proceed normally. Not the ideal solution, but it avoids any repeated attemps.

Interesting. I shall try this out and get back.

Well, the code uploaded, but it does not work. The serial monitor shows nothing. I am now starting to suspect that the firmware file is not uploaded on the board. I shall revert with more findings.

Welcome to RAK forum @esccrasci ,

I did various test on RAK3172-SiP firmware using latest RUI3 version 4.0.0.

All works fine on my end both on OTAA test via AT command and RUI3 API firmware.

I tested with your code with simple scheduler API and it compiles with no issues in consecutive upload attempts.

However, I need to understand what you expect on this code when you said

I am not sure what you expect but if I issue ATZ to reset the device after uploading your firmware, I see the initial serial print based on your code.

I am using a Silicon Labs CP210x USB-Serial converter on my RAK3272-SiP Breakout Board. FTDI chips are pretty robust as well but if you have extra USB-Serial converter, might be good to try as well.

Thanks a lot @carlrowan . The ftdi chip did work. I reflashed the firmware, and also used ATZ for a software reset. And those worked. Thanks a lot once again for the quick confirmation and the support! :pray: