Unable to send AT commands!


Juste received 2 brand new RAK7201 but I struggle to succeed to configure them :frowning: I have plugged it by USB using supplied cable at computer. I start minicom setup at 115200 baud on the proper serial port. If I go into setup mode or leaving it holding 3S the button 1 I see well text logged by device but I can’t send any commands at all :frowning:

Bienvenue dans minicom 2.8

Port /dev/ttyUSB0, 15:45:36

Tapez CTRL-A Z pour voir l'aide concernant les touches spéciales

Button 1 is pressed.
Button 1 is long pressed.                          
Device run low power mode.                         
Button 1 is pressed.                               
Button 1 is long pressed.                          
Device run configuration mode.

First rak device I’m not able to communicate through serial on USB command :frowning: Any ideas what’s wrong ?
I have resetted it also with success but not better to connect at it properly :frowning:
I tried also on a different computer but exact same behaviour !



I’d really appreciate to know what the Rak terminal tool for RAK7201 is doing differently from a regular terminal application ?? as it’s very annoying to have to use a specific program just to setup it (all the more when the program only exists for the worse OS in universe :frowning:

Also someone at Rak should update the docs for that device regarding TTN V3 connection as the process indicated is totally outdated (TTN web interface lists the RAK7201 now so setup is very minimal compared at previously :wink:

Hi @vincen You can use any Serial tool, you need just to set it up to send the \r\n (CR/LF) on every line. Manually or automatically.
UART Assistant for Win for example:

And Cutecom for Linux:

As for the minicom, probably one of the two is not set.

Yes, we are working to update the quick starts :slight_smile: Thank you for pointing this out :wink:

@velev Thanks for the trick for Cutecom and works perfect then :slight_smile: For minicom I had tried with CR/LF or only one of each but still not working, very strange !

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.