Update firmware 7249 failed, can't connect

Hi everyone, I recently brought a RAK7249 in from the field to upgrade the firmware and setup OpenVPN so I can remotely log in. I have done this to a number of others without an issue. This particular gateway, once I selected the version 1.0.1_RAK.bin file, and left it for a while to upgrade. When I came back it wasn’t available, and I can’t find the ip (and doesn’t connect on either). I had the upgrade set to save the configuration, and dhcp was set to automatically get ip. I have also taken to another computer, no luck there either.
Any thoughts? Is there another way to install firmware?

Hi @Andy Do you see the WiFI AP at all? You can open the enclosure and hold the reset button for 10 seconds to start the factory reset. It should show up after this. Your configuration will be lost. You can try to connect to the GW with an ethernet cable before the reset procedure, following this guide.

thanks for the assistance @velev, so far no luck. I tried the instructions to connect via ethernet via the link, no luck. I tried resetting the device, still no luck. Also tried the 30/30/30 to reset, no change. Here is what the unit looks like (led’s may indicate something?). The second led to the lower left of the device does flash 5 times before going out on unit startup.
ADD: I had the wifi off in my settings, so assume it’s not available.
ADD: I note that the led 2 should be solid to have ethernet, and flashing if sending/receiving data…so that’s obviously the issue, but a reset doesn’t seem to work, holding the reset button does nothing at all.

Any chance to have a console cable? Like this one for example?

Don’t have one, but have ordered. Will await instructions and proceed when cable arrives. Thanks.

Keep us updated. Instructions can be found here.

thanks @velev, cable arrived and am attempting as per instructions.
Got as far as setting a static ip ( I unplugged my existing ethernet cable and directly connected the ethernet from the gateway to computer (through a poe injector to power device). I ran Tftpd64 and placed the renamed recovery.bin file in the folder, see screenshot.
Putty connects correctly, so I have the correct com port (12 in this case).
I have both cables connected to the gateway, power it up and select “2”, Y, used the default ip’s as per the instructions, but this doesn’t seem to work…It just keeps looping through a timeout…and the tftpd64 log viewer doesn’t show anything.
I’m sure it’s something simple I’m missing, any help would be appreciated.

Success, thanks @velev for the assistance. Moved it all to another computer and redid everything as per the instructions and it worked perfectly.

Connecting fine through ethernet etc now…but the device is really sluggish in it’s response compared to other gateways. When I do something as simple as selecting Network/cellular from the main status page, it takes well over a minute to refresh. Any ideas what’s happening here?

Great that you manage to flash it. Can you try to make a factory reset from the WebUI?

If this doesn’t solve the slow response, please DM me.