Updating RAK4631 to RUI3

I have a RAK4631 in a RAK19001 base board and have been uploading firmware based on the Arduino BSP to it for a few months.

Today I wanted to try RUI3, so I followed the guide for updating RAK4631 to RUI .

I successfully updated the bootloader to rui3_nrd52840_bootloader, but updating the application to rui3_rak4631 fails with:

.\nrfutil.exe dfu serial -pkg '.\RAK4631_latest_dfu_package.zip' -p COM3
  [------------------------------------]    0%
Traceback (most recent call last):
  File "nordicsemi\__main__.py", line 1555, in <module>
  File "click\core.py", line 1137, in __call__
  File "click\core.py", line 1062, in main
  File "click\core.py", line 1668, in invoke
  File "click\core.py", line 1668, in invoke
  File "click\core.py", line 1404, in invoke
  File "click\core.py", line 763, in invoke
  File "nordicsemi\__main__.py", line 1073, in serial
  File "nordicsemi\__main__.py", line 988, in do_serial
  File "nordicsemi\dfu\dfu.py", line 127, in dfu_send_images
  File "nordicsemi\dfu\dfu.py", line 95, in _dfu_send_image
  File "nordicsemi\dfu\dfu_transport_serial.py", line 256, in send_init_packet
  File "nordicsemi\dfu\dfu_transport_serial.py", line 421, in __execute
  File "nordicsemi\dfu\dfu_transport_serial.py", line 502, in __get_response
pc_ble_driver_py.exceptions.NordicSemiException: Extended Error 0x07: The array of supported SoftDevices for the update does not contain the FWID of the current SoftDevice.
[1752] Failed to execute script '__main__' due to unhandled exception!

Do I have to download a SoftDevice before this? If so, which softdevice?

You do are uploading the wrong firmware file.

After updating to RUI3, you need to upload rui3_rak4631_latest, but your log file shows you are trying to upload an Arduino BSP firmware, not the RUI3 firmware.

Please follow the guide here: Device Firmware Upgrade | RAKwireless Documentation Center

Thanks @beegee, that worked.

At first nrfutil failed with “The firmware version is too low”, but I used JLink with SEGGER J-Flash to erase everything in flash, followed your instructions for flashing the bootloader and then followed the steps to upgrade to RUI and it worked.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.