Upgrade firmware - crash - how recovery


I was upgrading firmware of RAK7249 to the newest V1.1.0063_Release_r205.
But the upgrading of firmware failed and the RAK7249 is bricked. Can you send me instruction for firmware recovery?


What type of gateway are you? What was done during the burning?

The gateway is the RAK7249, i supposed update to corrupt firmware.

Can you tell me the specific model? Is the power off during the burning?

Thank you for your support.
-The model is RAK7249 Macro Outdoor Gateway - Bundle 2 - EU868
-Is the power off during the burning?
No, but after 1h I disconnected and fed it but nothing.

Maybe it’s not completely bricky, but you can assign an IP to it via a router, and then go back and search for its WiFi when you lose power.

Tried, but no activity on the rj45, the wifi is not seen and anyway it was disabled before the update. Help me !!

An unofficial but likely effective method is to setup a serial connection, wired Ethernet, and serve the correct firmware via TFTP.

See Gateway not connecting to WLAN/LAN after firmware update for a situation with the similar platform of the 7258


Before using TFTP, I suggest you do a forced reset.

If it is not caused by a burning error, you can open the gateway and press restart.

Long press the red button more than 5S!

I tried to press the reset button for a long time and in various ways. But the situation does not change, I think the only way is to use TFTP, what can I do? Help me!!!

As mentioned in @cstratton post, the final solution is provided and I hope it can help you.

Resolved with TFTP and using Tftpd64

:+1: :+1: :+1:
You are very good!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.