"USB device not recognized" error.

When I plug my RAK 4630 module into my computer via USB, I get the “USB device not recognized” error.

Welcome to RAK forum @kapucu ,

There could be many reasons why, but I hope it is not damaged.

Some questions so we can check what can be the reason:

Is the RAK4630 connected to a custom board or a wisblock baseboard? Does it work before or immediately not detected? Did you observe any hot areas on the board? Are there other modules connected? What OS did you use (windows, macOS, linux)? Did you try different USB cable or different USB port? Did you try to test on a different PC?

I have the same issue. I upgraded MacOS to Sonoma and now the 4630 module is not recognized by the OS. USB port does not show up.

sh-3.2# ls /dev/cu*
/dev/cu.BLTH /dev/cu.Bluetooth-Incoming-Port

Any clue to make it work again?
Thank you and cheers

I figured out the issue. It was not enabled the upload mode in the unit. Clicking twice the RESET button made the trick.

1 Like

Had same issue, didn’t recognize the COM port. Worked for me aswell. Thanks for the answer!

Unfortunately, my problem was not solved. I designed a circuit identical to the diagram below. When I connect it to the computer, I get the error “USB device not recognized”. I am very sure that there is no error in my connection. Is this diagram correct?

Is there a need for a USB TTL converter for programming?

The RAKDAP1 is a USB TTL converter.

But the RAK4630 bootloader supports only firmware updates through USB. You cannot update the firmware over the UART. It would require a different bootloader.

The RAKDAP1 is as well a DAPLink adapter, you can use it to flash firmware over the SWD interface:

Using RAKDAP1 over SWD on RAK4631

I am using RAK4630 for programming. I made the connection according to the schematic I posted above. But it didn’t work. I’m getting a USB device not recognized error.

2nd question
If I use USB TO TTL FT232RL, can I connect and use it via UART?

Looks different to your schematic.

  • You added a diode in the VBUS before connecting to the RAK4630
  • Not sure what’s below the RAK4630, but you missed some GND pins

Other than that it looks ok.

I would try to connect VBUS directly to the RAK4630:

Even if I short circuit the diode it doesn’t work. I tried every method imaginable