Using TLS in MQTT Gateway Bridge


I am trying to set up the RAK7249 Gateway to use TLS with MQTT to communicate with LoRaServer. The server is established from the example that was available at your website with the gateway documentation. I am able to set RAK7249 to use only MQTT, and everything works fine. When I want to enable TLS here, the gateway is not able to send anything, nor to connect to LoRaServer. I followed the tutorial you have provided with the gateway (document RAK_LoRaWAN_Commercial_Gateway_Application_Note_V1.2.pdf), and I have done everything as it is said in it. I used your script to generate certificates, and then set mosquitto, loraserver and gateway to use it.
I tried to debug the issue, where I tried to manually make a topic from gateway and subscribe to it from LoRaServer, but I encounter an issue on the gateway with the return message “Connection refused!”.
However, if I try this on the LoRaserver itself (both publish and subscribe), everything works fine.

Do you have any idea what can I do to solve this?

Thanks in advance!