Vscode BSP installation error

Context: MacOS / vscode / Arduino / RUI3

I’m (again/still?) working my way through “Configuring the Visual Studio Code” and I’m at the “9/ Install the RUI3 BSP” step.

Unfortunately, when I click install, this is what I see.

The only point where I know I deviated from the script is that I clicked the “use Arduino CLI” option because the legacy Arduino IDE is deprecated and there is currently no intention to support Arduino IDE 2.x. The Arduino Extension installation notes strongly suggests everyone uses the CLI that now comes bundled with the extension since version 0.5.0. We’re at version 0.6.0.

What am I doing wrong this time?

No idea :thinking:
I am using the Arduino Extension with the “use Arduino CLI” option as well.

What Additional BoardManager URL do you use?
This one should work:


Just uninstalled RAK4631, removed all cached files from the ArduinoIDE folder and installed it:

This is the same. I just copy/pasted it from the instructions page.

I have only Windows, no MacOS.


Could it be a MacOS problem? Can you check?

Hi @psupine @beegee

On my macOS v11.6.7 (Big sur), I was able to install the boards.

I am not using macos now as my daily machine so i upgraded my rui3 from the old v3.4.2 to the latest v4.1.1. It was successful for all cores.

btw, in this machine, i have the legacy arduino and modern arduino v2.x.x installed. i am not sure if that has any effect.

maybe you can also try other 3rd party packages and see if vscode will be able to get the those packages. it can also be that the issue is not just for rak rui boards.

Yeah … good test. I tried installing the “Arduino nRF52” BSP → same error.

It’s an almost new (stock) VScode installation, so I’ve got nothing to lose by ripping it all out and starting again. I’ll report back on the outcome.

It seems to be a permissions problem under MacOS Sonoma. I had to whitelist VScode in three places.


Now I just have to run down configuring the various Arduino #includes that aren’t being found automatically.

That last step ended up being simpler than I thought:
CommandPallete:: Arduino:Initialize

Now that I can (finally) load a VScode project that started out in the Arduino IDE, what’s the advantage/disadvantage of platformio over the Arduino extension (using RUI3 on a RAK4631)?

My eventual goal here is to get the JLink debugger going so I can move beyond println based debugging.

And a side question that isn’t worth a whole thread, there is a new error message showing up on the serial monitor stream.


I think this is new in RUI3(4.1.1) that I have installed thanks to @beegee 's hex image.

Advantages when using Visual Studio Code

I don’t think +EVT:JOIN_FAILED_RX_TIMEOUT is new. It just means the device didn’t receive the Join Accept message.

No, I’m absolutely sold on VScode rather than ArduinoIDE, which is why I have stuck with the (for me) troublesome task of getting it working.

My question is rather about the option of Arduino extensions or platformio extension under VScode. I had the impression that you and most if not all of the dev team are using platformio, but platformio is not discussed on the “RUI3 supported IDEs” page.

I had never seen the EVT timeout message until a week ago. I am not yet trying to use any radio links. I have my custom drivers for the GNSS and lots of numerical code running, but the radio links are for later. It might be that there is an attempt to communicate setting that I have inherited from your hex flash dump that is new for me.

At the moment RUI3 is only available as Arduino BSP. So in VSC you need the Arduino extension.
I didn’t find a way yet to use RUI3 BSP with PlatformIO. If you know how, please share. I will be the first to use it :grin:

That’s where I was playing when I bricked the micro. I’m not going back down that rabbit hole until my mental health is back up to default!

Do you have a JLink working out of VScode+ArduinoExt?

No, I am using Ozone for debug with JLink

I did manage to get the JLink debugger to work at one point from the Arduino2 IDE.

I think I built the Sketch configured for RAK4631, uploaded and then told the IDE it was a Nano 33 BLE instead, and then attached to it for debug. I could step through the source, including the RUI3 source which I thought was pretty cool, because it was the first time I’d seen into that code. At least I think it was RUI3 code ???

If I find a way, I will share it.