WARNING: [gps] could not get GPS time from GPS

My Gateway is RAKWireless gateway RAK2245 version 2.9.2R with a firmware RAK7243_based_on_Raspbian_OS_V2.9.2_20190820. Following the Get Start pdf i installed and configure the gateway and all it works except the gps.
I checked the serial and the gps is on ttyAMA0 and i get NMEA output from it.

i tried to stop ttn-gateway.service and start the start.sh with sudo ./start.sh inside /opt/ttn-gateway/packet_forwarder/lora_pkt_fwd but it don’t work.


Can someone help me?

You’d better take the corresponding firmware and test it again, which may be the root of the problem.

2245:Firmware

I installed the corresponding firmware but it don’t work. I’m still receiving the same error.

Make sure your GPS antenna is connected to the board and can pick up GPS signals, and make sure your raspberry pie has enough power to power up. If the same problem still occurs, please send the screenshot to me. Thank you.

Francisco, Did you ever get this resolved? I’m having the same problem (I think) but have not been able to find a solution. If you did, I’d like to know how you did it.

David

Hi @hdtodd do you have RAK2245 or RAK7243 Gateway?

I’m running a RAK 2245 PiHat on a Pi-3B+

And you are using this https://downloads.rakwireless.com/en/LoRa/RAK2245-Pi-HAT/Firmware/RAK2245%26RAK831_based_on_Raspbian_OS_for_RPI3_V4.1.0_20191202.zip or this https://github.com/RAKWireless/rak_common_for_gateway firmware? If unsure pleas run sudo gateway-version in RPi shell and give the output.

I’m using the https://github.com/RAKWireless/rak_common_for_gateway firmware that I installed yesterday with ./install.sh --chirpstack=not_installed.

gateway-version gives:

Raspberry Pi 3 Model B Plus Rev 1.3, OS “10 (buster)”, 4.19.97-v7+.
RAKWireless gateway RAK2245 version 4.2.0R install from source code.
Gateway ID: B827EBFFFE9436FB

Francisco and David, Did you solve this error? I think I having same problem but unable to find solution. If you did, I’d like to know how you did, my hardware is little different (Ras_pi 4 + pi_hat + rak2287).

pasrk,

I haven’t worked on this for two years or so, but looking at this thread and trying to reconstruct what happened, I think the problem in my case was that the antenna that RAK sent was bad.

In email with RAK support, nothing we tried fixed the problem. They sent a new board and antenna (right when Covid was starting up). For some reason, I tried the new antenna on the old board, and it worked. I swapped the old antenna back onto the old board, and it failed again. So I left it with the new antenna on the old board. I didn’t even unpack the new board.

Your failure could be because of software or misconfiguration, board failure, poor antenna connection, faulty antenna cable or antenna. Check your antenna socket and plug with a magnifying glass to make sure the connecting parts aren’t bent and not connecting. If you can get a GPS antenna with the same connector, try it.

Don’t assume yours is failing because of software: it could be hardware. I spent a long time figuring that out.

Thank you David, I will follow that for sure.