Wis11300 core got stuck. No port detected

Hi There! I already have some (successful) experience with wisblock modules but I’ve never had this issue before.
I’m programming a wis11300 core with a base 19011 which supports 2 IO boards.
Also I added a 5802 (RS485) for modbus communication and wis13002 for IO headers
During initial tests trying different modbus libraries and different configurations, the board started to dissapear from the COM ports.
I got an error like “Cannot perform port reset: TOUCH: Error during reset: opening port at 1200bps
Then, remembering from other boards, I tried double clicking the RST button right while it was trying to upload and it worked.
This kept going on everytime I had to upload code, and then finally it got to a point where double clicking RST woulnd’t do anything. RED light is ON as usual, but green light didn’t come up like the last times
Also Windows doesn’t see this COM port, and it doens’t play the usual chime when I plug it in and out… So to this computer it’s like DEAD, but it’s still powered
Luckily I bought a second set and progression was the same, very soon I had to start using the double RST to allow it to flash, but this one didn’t end up fully failing.
Later on when I uploaded a basic sketch it all came back to working fine, being able to see the COM port normally, so I guess there was some combination of librariesand pin usage in my sketch that got the serial port stuck. Now I have a working modbus RTU master sketch working fine, but I still have a non working board.
Is there any way to try to bring this board back to life? Any hint on what could have got it to this situation?

Thanks everyone!

Welcome to the forum @edugimeno

Do you have access to a JLink or DAPLink adapter. If yes, can you try to do a chip erase, then flash a new firmware through JLink/DAPLink and check if it improves the situation?

I have one board (not with me right now) that I believe is a jlink programmer. In such a case, do you have a link to a guide that provides directions on

  • What programmer to use
  • Firmware to upload

Thank you!

We do not have a “guide” how to flash with JLink. It is straight forward. I am using Segger J-Flash application.

Setup project like this:

Drag HEX file with firmware to J-Flash

Push F7 to flash.

Ok I just got a hold of the device, It is actually an AVR USBASP programer, it cannot be used a jlink programmer right?


No, I think that works only with AVR MCU’s.

Ok so I guess I will throw it away as getting a jlink programmer, taking the time to understanding how to program it, and also the risk that programming it wouln’t solve it, is not worth compared to getting a new board